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Lesson 1: Downloading, installation, pluginsto Quantum Geographic Information 
System (QGIS) software 

 

Objective:Understand the basic concept of GIS, raster, vector,projections,geo-processing and analysis.Use a 
GIS for basic skills in: thematic mapping, importing tabular data and GIS interpretation, basic vector data 
analysis, finding and using open access data, styling and map design. 

Software: Quantum GIS 3.6.3 

System/Hardware Requirements: 

• Processor-CPU : core i7 64 bit Processor 
• Memory RAM : 8 GB or more 
• Hard Disk : SSD de 128 Gb or 500 Gb SATA 
• Graphic card : 2 Gb RAM 
• Operating System : Windows 10 

Web Browser : Google Chorme 

Quantum GIS is an Open Source Geographic Information System. The QGIS software package currently runs 
on most versions of Unix, Windows and Mac OS X and supports a number of common raster and vector data 
formats. QGIS is available under the GNU General Public License (GPL). 

QGIS aims to be a user-friendly GIS,providing common functions and features.The initial goal of the software 
was to provide a GIS data viewer. QGIS is available at no cost to users and provides an alternative to costly GIS 
software. 

Methodology: 

Downloading QGIS Software:  

Step1. To install the software QGIS must choose the web browser of your choice on your computer (for 
demonstration we are using Google Chrome).In your preferred web browser navigate to the QGIS download 
page: http://www.qgis.org/en/site/forusers/download.html 

Step2. Based on your operating system (Mac OSX, Windows, Unix) locate the “latest release” and download 
the “QGIS Standalone Installer.” The examples below outline the Download for Windows and Mac OSX 
(Version3.6.3) 
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*If you are a Windows user, be sure to check your machine and download the correct file based on system type 
(32 bit vs. 64 bit). This can be done by right clicking on “Computer” in the start menu and selecting 
“Properties” 

Installing QGIS Software: 

1. After the file download has completed (about 2-5 minutes depending on connection), run the ‘.exe’ program. 
The file name will be similar to “QGIS-OSGeo4W-3.6.3-1-Setupx86_64.exe” and can be located in your 
default downloads folder.    

2. After running the file and accepting the terms of agreement, select where you would like the program saved 
under “Destination Folder” (default is recommended).  

 3. Select the components to install.  

4. Click “Install.” 

5. After the installation, shortcuts will be placed to the desktop and the start menu. To open QGIS, click on the 
“QGIS Desktop 3.6.3” or QGIS Desktop 3.6.3 with GRASS 7.6.1” icon. 

QGIS Plugins: 

Plugins in QGIS add useful features to the software.Plugins are written by Qgis developers and other 
independent users who want to extend the core functionality of the software.These plugins are made available in 
QGIS for all the users. 

Plugins are optional tools that you can download and import into your QGIS for additional functionality.  

A useful plugin for QGIS is ‘GeoreferencingGDAL’.This is core plugin-meaning it is already part of your 
QGIS installation.You just need to enable it. 
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1. After opening the QGIS Desktop application, Go to the Plugins > Manage and Install Plugins and enable the 
Georeferencer GDAL plugin in the installed tab. 

2.The plugin isninstalled in the Raster menu.Click on Raster>Georeferencer to open the plugin. 

 

Exercise 

1) Which of the following statement is true? 
A) QGIS is a proprietary software 
B) QGIS is an open source cross platform 
C) QGIS can’t be downloaded freely 
D) All the above 

2) GPL stands for :………………………………………………… 
3) GUI stands for :………………………………………………… 
4) SCP stands for :………………………………………………… 
5) What does the abbreviation QGIS stands for? 

A) Qualitative Geographic Information System 
B) Quantum Geographic Information System 
C) Quick user Geographic Information System 
D) Quarterly Geographic Information System 

6) The additional external tools can be bought to QGIS using following option 
A)  Import button 
B) Export button 
C) Plugins 
D) Vector tools 

 

 

 Conclusion: 

 

 

Video Link: 

https://youtu.be/c1s0N4lQ48g 

  

https://youtu.be/c1s0N4lQ48g
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Lesson 2:Geo-referencing of a topo sheet in QGIS software 

Objective: Geo-referencing a toposheet by using graticule intersections in a known coordinate system and 
datum.  

Software: Quantum GIS 3.18.3  

eoreferencing is a process of establishing a mathematical relationship between the image coordinate system 
and the real world spatial coordinate system. This mathematical relationship can be assigned by any one of the 
transformation settings, viz. Polynomial order 1, 2 or 3, Linear, Projective and Thin Plate Spline etc. 
Polynomial order 2 is the most widely used transformation in Georeferencing. Recently Thin plate Spline 
gaining popularity due its ability of incorporating the local deformations in the data, this is very useful when we 
are dealing with low resolution data. However in this practical we are using traditional polynomial order 2 
transormation or Thin plate Spline to perform georeferencing/rectification of the Toposheet. 
 

Workflow:  

1. Open QGIS software 
2. Add the topo sheet(the Menu bar (Layer > Add Layer >Add Raster layer) 
3. Open georeferencer (Raster > Georeferencer)  
4. Go to File > Open Raster.Browse to the folder,select image (North 24 parganas-scaled.tif) and click 

open. 
5. Add GCP points or add points from map canvas  
6. In the pop-up window,enter coordinates.Remember that X=longitude and Y=latitude.Click ok. 
7. Go to Settings > TranformationSettings.In the Transformation Setting Dialog ,choose The 

Transformation Type as Thin Plate Spline. Resampling method > Nearsrst neighbor. Name Your 
output raster as toposheet_referenced.tif.Choose EPSG:4326 WGS 84 (EPSG: European Petroleum 
Survey Group) as the target SRS so the resulting image is in a widely compatible datum.Make sure the 
Load in QGIS when done option is checked. Click ok. 

8. Back to Georeferencerwindow,Go to File >  'Start Georeferencing' Button. The processing will take 
at about 2 minutes. Once the process finishes,you will see the referenced raster layer (North 24 
parganas-scaled_GCS.tif)loaded in QGIS. 
 

Methodology: 

1. Registering a raster images using GCP’s (Ground Control Point) 

1. We start by opening the georeferenced image in QGIS by clicking on the 'Add Raster layer' button  
or via the Menu bar (Layer > Add Layer >Add Raster layer) 

2. Click on Raster >Georeferencer to open the Georeferencer GDL plugin. 
The plugin window is divided into 2 sections. The top section where raster will be displayed and 
bottom section where table showing your GCPs will appear. 

3. Go to File > Open Raster.Browse to the folder,select image (Toposheet.tif) and click open. 
4. Image will be loaded in the top section.Need to assign coordinates to some points on this map. 

To georeference an image we use Ground Control Points (GCPs). GCP is a location on the earth's 
surface with known coordinates on both earth and Toposheet.Zoom to area and click on Add Point 
Tool and click on the image location. 
. 

G 
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5. To start adding GCPs to our map, we first zoom to a corner of the map where we can easily identify 
the intersection of the latitude and longitude. Use the scroll wheel of the mouse to zoom in and out of 
the map. Use the  'Pan' Button when needed. 

6. In the pop-up window,entercoordinates.Remember that X=longitude 
and Y=latitude.Click ok. 
 

we will require minimum 6+1(for check) i.e., 7 GCPs or more GCPs on the 
map. Therefore, we need to mark atleast 7 GCPs. The GCPs locations should 
be spread out as much as possible and they should not be co-linear at the same 
time they should enclose our whole area. Use the above procedure to mark six 
more control points. 

7. Go to Settings >TranformationSettings.In the Transformation 
Setting Dialog ,choose The Transformation Type as Thin Plate 
Spline.Resampling method >Nearsrst neighbor Name Your output 
raster as toposheet_referenced.tif.ChooseEPSG:4326(EPSG: 
European Petroleum Survey Group) as the target SRS so the resulting 
image is in a widely compatible datum.Make sure the Load in QGIS when done option is checked. 
Click ok. 

8. Back to Georeferencerwindow,Go to File >  'Start Georeferencing' 
Button. The processing will take at about 2 minutes.Once the process finishes,you will see the 
referenced raster layer (toposheet_referenced.tif)loaded in QGIS. 
 
 

2. Registering a raster images using Map canvas 

In case, the GCPs are not available to the users, georeferencing process can be done by using a map which is 
already georeferenced. In the step no 4 (Registering a raster images using GCP’s (Ground Control Point)), Go 

to Add 
pointTo
ol and 
click on 
the 
image 
location. 
Then 
select 
From 
map 
canvas 
option. 
The 
display 

window of QGIS will open where the georeferenced map is already loaded. Click exactly on the same position 
over the georeferenced map. It will take the coordinates of that point. After doing the same process for at least 7 
points follow the similar steps described in the above section.  
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Exercise 

1) The process of assigning real world coordinate to raster image is called as- 
 
  a) Rectification 
  b) Image rectification 
  c) Geo-referencing 
  d) None 
 
2) EPSG stands for………………………………………………………………….. 
3) Full form of GCP is ……………………………….. 

 

Conclusions: 

 

 

 

 

Video link: 

1) https://youtu.be/dkHsfIAryA8 

2) https://youtu.be/X2_jyWcZ7oo 

 

https://youtu.be/dkHsfIAryA8
https://youtu.be/X2_jyWcZ7oo
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Lesson-3: Digitization and area calculation using QGIS software 

Objective:To delineate different types of land use features on the toposheet. 

Digitization is the process of converting analog data into digital data sets. In GIS context digitization refers to 
creating vector datasets viz., point, line or polygon from raster datasets.  With the help of digitization we can 
create different set of layers Viz. Rivers, roads, schools, ward boundaries and building blocks from a single 
map; this process is known as Vectorization. Vector data is easy to edit, update and is more accurate as 
compared to raster data. Vector data is more efficient for GIS analysis.  

Vector data is mainly of three types – 

• Point: It consists of single points having (X, Y) coordinates, for example lamp posts, bus  
stops and postbox positions etc.   

• Line: It consists a series of (X, Y) coordinates 
in a sequence (from start node to end node 
with a number of vertices joining these two 
nodes). For example roads, power lines, ward 
boundaries and contours etc. 

• Polygon: It is a series of (X, Y) coordinates in 
a sequence closing a figure where first  

and last points are the same. For example lakes, 
building blocks, village blocks, ward  
areas and forests etc 

Workflow: 

1. Open QGIS software 
2. Import the raster layer 
3. Create a new shapefile layer 
4. Choose the type of features (point, line or polygon) 
5. Add the field names and add those to the list 
6. Save the file with projection system 
7. Select the file in the layer panel and activate the Toggle editing option 
8. Digitize the features using Add feature tool  
9. Calculate the area and length of polygon and line features respectively using the field 

calculator  
 
 
Detailed methodology: 
 
Open the raster layer of georeferenced toposheet in the map canvas of Quantum GIS via, ‘Main menu bar 
>Layer >Add Raster Layer’ >browse and select the georeferenced raster layer>Click on ‘Open’ in the 
popup window.  

Create Point Shapefile : 

1. To create new point layer, go to main menu bar in QGIS interface and select ‘Layer’ > ‘createlayer’ > ‘New 
Shapefile Layer’. 
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2. Now the ‘New shapefile Layer’ window will popup. Select ‘Geometry type’ as ‘Point’ as we are interested in 
creating a point layer.  

3. Specify CRS (Coordinate reference system) same as original layer, i.e., as ‘EPSG:4326 - WGS 84’. To do 
this click on ‘Specify CRS’ > Select the ‘WGS 84’ under Coordinate reference system of the world >Click on 
‘OK’ 

4. We can add new required attribute fields to the vector layer that we have created. For example if we are 
creating point vector layer of all hospitals we can add ‘Name’ of the hospital as new field and ‘intake capacity’, 
‘Address’ etc. as other fields.   

For Each New attribute  added, an appropriate name, type of the variable (like text, whole number, decimal 
number and date) and width must be selected. Click on ‘Add to Field List’ and the attribute will be added to the 
list. Now add the attributes details shown in the below figure. 

5.For Each New attribute  added, an appropriate name, type of the variable (like text, whole number, decimal 
number and date) and width must be selected. Click on ‘Add to Field List’ and the attribute will be added to the 
list. Now add the attributes details shown in the below figure.  

6. Once the required attributes are added, click on ‘OK’ 

7. Now you will be presented with ‘Save As’ window, save the file in appropriate drive with appropriate name 
for example: Hospitals.shp. Once the layer is saved it opens up as point data layer under map legend.  

8. To start digitization, we have to enable the editing mode of the corresponding vector layer. Right click on 
‘Hospital..shp’ point layer and click on ‘Toggle Editing’ or select the layer and click on  icon from ‘Digitizing’ 
toolbar and click ‘Add point feature’. 

9.You will notice a pencil symbol on left side of the layer name. This tells you that the layer is ready for editing.   

10. Zoom into the toposheet where hospitals are present, the symbol of hospital in the given toposheetis . Click 
on  ‘Add point feature’from digitizing toolbar.   

11. Place the pointer at the center of the feature of interest and click.   

12. You will be presented with an ‘Attributes’ window. Fill the required attribute information like ‘id’, ‘Name’ 
and ‘Address’. Click ‘OK’.  

13. The point will be created with the specified attributes at the specified location.  Now open the attribute table 
of ‘Hospital.shp’ by right clicking on the hospital layer and selecting ‘Open Attribute Table’. If you want to 
change any details, then simply select the attribute by double click and edit it.  

14. Similarly digitize the other hospitals in the toposheet. Click on ‘Save Layer Edits’  icon in ‘Digitizing’ tool 
bar, to save the edits. After saving click once again on the toggle button to stop editing. This will save the point 
layer along with its attributes. Double click  

 15. Go to attribute table of ‘Hospital..shp’ to check if the attributes are added properly or not. If not properly 
added, edit them as described in step 13. 

Create line shapefile : 

Line is basically used to represent any linear network such as road, railways and drainage etc. 
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1. To create line layer, go to ‘Layer’ > ‘createlayer’ > ‘New Shapefile Layer’. The ‘New vector Layer’ window 
will open up. Select ‘Type’ as ‘Line’ as we are interested in creating Line layer of roads and Specify CRS as 
‘EPSG: 4326 – WGS 84’. 

2.  Add required attributes, for example ‘Name’ as shown in above figure and click ‘OK’. ‘Save As’ window 
will open up. Browse to an appropriate location and give an appropriate name for example ‘Roads’ > click on 
‘Save’.  

3. The layer is created and will be listed in Map legend. Right click on layer, click on ‘Save’.‘Toggle Editing’ or 
click on  icon from ‘Digitizing’ toolbar.   

4. Zoom into the toposheet where roads are seen. Click 
on ‘Add Line feature’ icon  from‘Digitizing’ toolbar.   

5. Now trace cursor along the middle of the road by 
using left mouse button to insert vertices when you think 
the road changes its profile, this means you have to insert 
more vertices while digitizing bends to get smooth curve. 
When you reach a junction or at the end of the road click 
on the right mouse button to stop. Now ‘Attributes’ 
window will open, fill in the appropriate attributes for 
example Name is ‘Satara Road’ and click ok. 

6.  Snapping tolerance can be set manually. Go to View> Toolbars> Snapping Toolbar.Click on Enable 
Snapping’>Active Layer. 

7. Check the box to the left side of road network layer and set ‘type’ to ‘vertex and segment’. Specify tolerance 
as ‘5’pixels.Checkon‘Enabletopologicalediting’.Andclickok. 

 

8. So by use of the snapping tool it is possible to get an accurate intersection of roads. Once you finish 
digitizing all roads in the toposheet save the edits and stop editing by clicking on ‘Toggle editing’ button. Now 
the road network along with its attributes will be saved.   

Create polygon shapefile : 

Polygon is basically used to demarcate areas such as administrative parcels, forests, buildupareas and water 
bodies etc. 

1. To create Polygon layer, go toLayer’ > ‘create layer’ > ‘New Shapefile Layer’. The ‘New shapefile Layer’ 
window will open up. Select ‘Type’ as ‘Polygon’ and Specify CRS as‘EPSG: 4326 – WGS 84’. 

2. Add required attributes for example ‘Name’ and click ‘OK’. A save dialog will appear. 

Set snapping options 
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1.Go to view menu > Toolbars>Snapping Toolbar 

2. In the Snapping toolbar,First click the Advanced Configuration 
option,then Open Snapping Options;then open snapping options;as 
shown in the below figure 

 3. Now set the following things as shown given below 

 

Rater to vector conversion(also called screen  digitization) 

1. To start digitization of polygon boundary,click Toggle 
editing tool on the Digitizing toolbar. 

2. Click Add Polygon Feature Tool.to begin Digitizing. 
3. To place last point right click .this will finalize the feature 

and show attribute dialog > click ok > click Save layer 
editing tool. 

Geographic area calculation: 

1. Select the Polygon/Line layerfrom layer panel. 
2. Click the Open Field Calculator tool present in the Attribute 

toolbar. 
3. Select the crate a new field checkbox to save the calculation into a new field. 
4. Add Area/Length as Output Field name and Decimal number(real) as Output field type and define Output 

field length to be 10 and Precision 5. 
5. Now double click on function $area for area and $length for length in the Geometry Group to add it into the 

Field calculator expression box. 

 

Exercise 

1)  The difference between Raster and Vector is: 

  a) Raster is composed by pixels and vector is composed paths 
  b) Vector represents images and Raster represents points,lines and polygons 
  c) Raster represents data as cell or grid while Vector represents data using sequential points or vertices. 
 
2) Three basic symbol types for vector data- 
 
 a) Cells,Dots and Triangles 
 b) Points,squares and Plygons 
 c) 2D,3D, and Hybrid 
 d) Points,lines and polygons  
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3) The process of assigning real world coordinate to raster image is called as- 
 
  a) Rectification 
  b) Image rectification 
  c) Geo-referencing 
  d) None 
 
4) CRS stands for………………………………………………………………….. 
 
5)The process of distilling points, lines, and polygons from a scanned image is called…………….. 
    a) Digitizing 
    b) Scanning 
    c) Vectorization 
    d) Imaging 
 
7)GIS deals with which kind of data? 
   a) Numeric data  
   b) Binary data  
   c) Spatial data  
   d) Complex data  
 
 

Conclusion: 

 

 

Video Link: 

Digitization: https://youtu.be/08eufydgv5c 

Area calculation: https://youtu.be/VVKb6dgmMus 

                              https://youtu.be/Lx7hF2XpAgA?t=122 

 

 

 

 

 

 

 

 

 

https://youtu.be/08eufydgv5c
https://youtu.be/VVKb6dgmMus
https://youtu.be/Lx7hF2XpAgA?t=122
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Lesson-4: Field data collection using GPS device and data import to QGIS 

Objective: To collect the field data (location) and import data to GIS system 
Instrument: GPS Garmin e trex 10 
 

Methodology: 

1. Visit to the field. Collect the location (longitude and latitude) data using GPS device. 
2. Note the location data. Save the data in a “.csv” (comma separated value) file 
3. Import the “.csv” file in the QGIS through: Layer          Add layer          Add delimited text layer 
4. Data is imported as point file in the GIS system 

 
 

5. Export the file as a “.shp” file (vector file) 
6. Open the attribute table of the vector file 
7. Activate the “toggle editing” and add a new filed in the attribute table.  
8. Fill the newly added fields with the information collected during field visit corresponding to a particular 

location 
 
 
Exercise 
1. Which instrument is used in field data collection? 
2. In which format field data is to be saved for importing in GIS system? 

 

 

Conclusion 

 

 Video Link:  

        https://youtu.be/BPBa75DqWFI?t=124 

https://youtu.be/BPBa75DqWFI?t=124
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Lesson 5:  Map creation in QGIS 

Objective: to use the QGIS Print layout to create a basic map. 

Map Layout is the assembling of the varies elements of a map into a single whole,including the map 
itself,itslegend,title,scale bars and other elements. 

1. Open the map layers via the menu Layer → Add Vector Layer. the layer type to ‘ESRI Shapefiles’. 
Select all the layers by clicking on one and pressing CTRL+A. Click ‘Open’ 

(Now rearrange the layers in such a way, all point features are on top to line features and line features over 
the polygon features) 
2. Let’s start the map preparation by setting the colours for the base polygon layers.Right click 

polygon.shapefile> properties>symbology> symbol layer type > simple fill> fill color choose > apply > ok 
3. Go to project >  New  print layout. 
4. You will be prompted to enter a title for the layout.So write down any project name and Click ok.In the 

print layout window,go to Add Item > Add Map 
5. Once the Add Map button is active,hold the left mouse button and drag 

a rectangle where you want to insert the map. 
6. Click on Item properties tab and enter value for scale 
7. We will add grid and zebra border to the main map.   In the item 

properties tab ,scroll down to the Grids Section > Click the Add a new 
grid button. 

8. By default,the grid lines use the same units and projections as the 
currently selected.it is more common and useful to display grid lines in 
degrees.click on Modify grid…button and click change…. Button next to CRS. 

9.  In the coordinate Reference system selector dialog,enter 4326 in the Filter box.From the results,select the 
WGS84 EPSG:4326 as the CRS.Click ok. 

10. Select the interval values as 0.03000 degrees in both X and Y direction. 
11. Choose the grid type as Cross. 
12. Scroll down to the Frame Section and select a frame style that suits your taste. 
13. Also check the Draw Coordinate section.Display left and right coordinates in Vertical ascending order. 
14. In the draw coordinate section > format >degree,minute and suffix> font change 
15. Now add a north arrow to the map.Click Add Item > Add picture. 
16. Click on the item properties tab > Search directories section and select the North Arrow image . 
17. Click on Add Item > Add Scale bar. 
18. Click on Add Item > Add legend. 
19. Click on Add Item > Add Lebel. 
20. Export it as Image,PDF or SVG.Click Layout > Export as image 
21. Save the project. 
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Exercise 

1.  A small-scale map would show  

A. A larger geographic area than a large-scale map  
B. A smaller geographic area than a large-scale map 
 C. The same geographic area as a large-scale map, just at a smaller resolution  
D. The same geographic area as a large-scale map, just at a larger resolution 
 
2.  Maps that show much detail of a small area are called ________ maps.  
a. medium scale 
b. small scale 
c. large-scale 
 d. Very large-scale 
 
 3.  Maps that covers entire area without showing much details of a perticularsgment of an area is called  _____ 
maps.  
a. small-scale  
b. medium-scale  
c. large-scale 
d. very large-scale 
 
4.The map element that serves as a guide to the various colors and symbols on the map is the: 
a.scale bar 
b.north arrow 
c.legend 
 
5. WGS 84  stands for………………………………………………………………………………….. 
 

Conclusion: 

Video Link: https://youtu.be/UMQrmQa_yaU?t=627 

https://youtu.be/UMQrmQa_yaU?t=627
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Practical 6: Collection of open source satellite data 

Objective:To know and collect the open source satellite images. 

Web Browser:Google Chrome 

 
Download LISS Satellite Data 

 

Bhuvan is manoeuvre to display the diversity of Indian imaging capabilities including the thematic information 
derived from imagery is of vital importance to common man. Bhuvan an ambitious project of ISRO(Indian 
space research organization) to take Indian images and thematic information in multiple spatial resolutions to 
people with a web portal through easy access to information on basic natural resources in the geospatial domain. 
Bhuvan showcases Indian images by the superimposition of the IRS satellite imageries on 2D/ 3D virtual globe. 

Step 1: 

Go to Google Chrome >Serachbhuvan.nrsc.gov.in> Welcome to Bhuvan> Open data Archive > In the top-
right of the web map, click the  button Log in > Insert valid 
entries for your name, email, and location. Profile .Click 
Submit. 

 

STEP 2. Log in (after registering) 

1) This portal provides the user to access open data archive 
facilities under three categories of i) Satellite/Sensor, ii) 
Theme/Product, iii) Program/Projects and seven sub-
categories under satellite or sensor category as mentioned 
below: 

SCATSAT-1: Scatterometer 
Oceansat-2: OCM 
Resourcesat-1/ Resourcesat-2: LISS-III 
Cartosat-1 
Resourcesat-1/ Resourcesat-2: AWiFS 
 
2) Here we will select the category of satellite/ sensor and sub-category of Resourcesat-1/ Resourcesat-2: LISS-
III 

3) In in this step tile selection will be carried out in order to view and download details of that particular tile that 
is area enclosed by that tile. Once you recognized the tile of the area under your study click the start button 
located at the left bottom of the window. This will initiate the tile selection. After selecting tile click on next to 
proceed further. 
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4) Next click will divert the user to download window where tabular tiles available for selected area are 
represented. Here thumbnail and Metadata options are provided which will show metadata sheet and thumbnail 
view of bounding box > click download option 

5) Once the downloading started portal will send the feedback window displaying download will start with user 
name and optional way to start download if download has not stared. 
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Download LANDSAT Satellite Data 
Landsat :represents the world’s longest continuously acquired collection of spacebased moderate resolution 
land remotesensing .All Landsat data are available to the public at no cost from U.S. Geological Survey (USGS) 
websites. 

The USGS Earth Explorer interface uses Google Maps. You 
can zoom in and out with the mouse wheel as if you are in 
Google Maps. Google street view is also enabled, where you can 
drop a marker and get a real view of the location. 

 

Download Landsat Satellite Data 
First, you’ll have to create an account with USGS. In the top-
right corner, click the  Register  button. As it’s a pretty painless 
process, you’ll receive instructions to activate your account. 
 

STEP 1. Register as a user of USGS data and create an account. 
To be able to download data from Earth Explorer sites, you must first register and create an account. To register 
and create an account, go here: https://earthexplorer.usgs.gov/register/?return TIP: Be sure to prior to starting 
your search for Landsat scenes on USGS as the system will not let you download any data unless you are 
logged in. 

STEP 2. Log in (after registering) 

https://earthexplorer.usgs.gov/
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1. Search criteria > Enter search criteria > Select a Geocoding Method  > Path/Row > polygon  >  enter 
Path and Row number > show or at first study area find out > click Use map  

2. Data Range  >  Search from and to > Search months   
3. Cloud cover range 0 to 10% 
4. Data sets > Landsat > Landsat Collection 2  Level -1 > Landsat 8 OLI/TIRS C2 L1 or Landsat 4-5 Tm 

C2  L1 
5. Results > Click on the green download arrow   

 
Download Sentinel-1 and Sentinel-2 Satellite Data 

In 2014-15, Sentinel-1 and Sentinel-2A were successfully launched from Europe’s Spaceport in French Guiana. 

One Sentinel scene after the other, data has been rolling out on a user interface called the Sentinels Scientific 
Data Hub. 
It’s now available for the public to access. 
 
 
Follow these steps to download 
free Sentinel satellite data: 

Create a User Account 

STEP 1 
1.Go to Sentinels Scientific Data 
Hub> Open Access Hub-Copernicus 
> Open Hub 
 
2.In the top-right of the web map, 
click the  SIGN UP  button. 
3.Insert valid entries for your name, 
email, and location. Click register.  
4.Validate your email.With a few clicks of the mouse, you’ve gained access to ESA’s Sentinel data. 

Select Your Area of Interest 
STEP 2 
Where is your study area? 
Using the  SEARCH CRITERIA  text box in the top-left, type in your area of interest.In our example, we’ve 
typed Germany. Click Enter twice. 
 
Download Sentinel Data 

1) Choosing area, sensor, time period in the Sentinels Data Hub>Advanced search>sort by: Ingestion 
date/Sensing date >type sensing period>Select Misson :Sentinel-2 >select area >search 

2) After we perform the search, the results are shown in this way: 

 

https://scihub.copernicus.eu/dhus
https://scihub.copernicus.eu/dhus
https://scihub.copernicus.eu/dhus
https://scihub.copernicus.eu/dhus
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3) Then, by clicking in the “eye” icon, we are shown the details of each scene 

4) If this scene satisfies our needs, we might download it by just pressing the “arrow” button, at the bottom 
right.  
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Exercise 
1) LISS stands for ………………………………………………………………….. 
2) USGS stands for…………………………………………………………………. 
3) ISRO stands for………………………………………………………………….. 
4) Which is the latest Landsat satellite currently in operation: 

A) Landsat-5   
B)Landsat-7  
C)Landsat-8 

 5) MSS,TM and LISS -3 sensors are: 

A) Only passive sensors   
B) Both active and passive sensors 
C)only active sensors 
D) None of  the above 
 

6)The visible wavelengths cover a range from approximately: 

A) 0.4 to 0.7µm 
B) 0.7 to 1mm 
C) 0.4 to 1mm 

Conclusion : 

 

LISS data collection: https://youtu.be/H5DwXK7EMXk 

Sentinel data collection: https://youtu.be/kacMW92kxB8 

Landsat data collection: https://youtu.be/8BxTjdqCMUc 

 

 

 

 

 

 

 

 

https://youtu.be/H5DwXK7EMXk
https://youtu.be/kacMW92kxB8
https://youtu.be/8BxTjdqCMUc
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Lesson-7: Introduction to SAGA software: downloading, installation, loading and 
viewing of satellite image 

Objective: To get familiar with SAGA GIS interface and view and explore raster data in it 

Software: SAGA (System for Automated Geoscientific Analysis) GIS (6.4.0) 
 
System/Hardware Requirements: 
 
Processor-CPU : core i7 64 bit Processor 
Memory RAM : 8 GB or more 
Hard Disk : SSD de 128 Gb or 500 Gb SATA 
Graphic card : 2 Gb RAM 
Operating System : Windows 10 
 
Web Browser : Google Chorme 
 
SAGA (System for Automated Geoscientific Analyses) is an open-source digital image processing GIS program 
capable of processing images in different formats. It uses the well established GDAL/OGR library to import and 
export images to and from its native format, SAGA Grid (*.sgrd).   

System for Automated Geoscientific Analyses (SAGA GIS) is a geographic information system (GIS) computer 
program, used to edit spatial data. It is free and open-source software, developed originally by a small team at 
the Department of Physical Geography, University of Göttingen, Germany, and is now being maintained and 
extended by an international developer community. 

Methodology: 

Downloading SAGA Software:  

To install the software SAGA GIS must choose the web browser of your choice on your computer (for 
demonstration we are using Google Chrome).In your preferred web browser navigate to the SAGA GIS 
download page: http://www.saga-gis.org/en/index.html> Downloads (Version 6.4.0).SAGA is available as a 
stand-alone program which means it does not have an installation procedure 

 

 

 

 

 

 

 

 

 

https://en.wikipedia.org/wiki/Geographic_information_system
https://en.wikipedia.org/wiki/Computer_program
https://en.wikipedia.org/wiki/Computer_program
https://en.wikipedia.org/wiki/Open-source_software
https://en.wikipedia.org/wiki/University_of_G%C3%B6ttingen
http://www.saga-gis.org/en/index.html
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*If you are a Windows user, be sure to check your machine and download the correct file based on system type 
(32 bit vs. 64 bit). This can be done by right clicking on “Computer” in the start menu and selecting 
“Properties” 

 

Installing SAGA Software: 

1. After the file download has completed (about 2-5 minutes depending on connection), run the ‘.exe’ program. 
The file name will be similar to “saga-6.4.0_×64_setup.exe” and can be located in your default downloads 
folder.SAGA is available as a stand-alone program which means it does not have an installation procedure. To 
start SAGA, navigate to the SAGA folder, look for the  ' saga_gui.exe ' icon and double-click on it.   

2. After running the file and accepting the terms of agreement, select where you would like the program saved 
under “Destination Folder” (default is recommended).  

 3. Select the components to install.  

4. Click “Install.” 

5. After the installation, shortcuts will be placed to the desktop and the start menu. To open SAGA GIS. 

Loading and viewing of satellite image 

Data requirement: Landsat TM 5 

Software: SAGA GIS 

1)We will start by opening an image in the program. To open the image, click on the  ' Load' button in the 
toolbar, or open it via the menu (File → Grid → Load) 
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2)This will open a window from where we must navigate to our image folder. The images may not be 
immediately visible.  At the bottom right of the window beside File name , there will be a drop down menu. 
Change the selection to ' Recognized Files '. Now, select four images with ‘*.tif’ extension (i.e., Band_2, 
Band_3, Band_4 and Band_5) and click 'Open'. This imports the images into temporary * .sgrd images.  

 

3)To view an image, double-click on respective grid (for example: 'Band_2'). This will open the image in a 
window in the work area section 

Note: If the image is not loaded in greyscale as shown below, you can set the greyscale color ramp by using: 
Settings Tab >Colors >Type: Graduated Colors > Scaling> Click on color ramp to browse >Presets >Select 
‘greyscale’ > OK > Click apply on Apply under ‘Settings’. 
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4) To the right/left of the map window is the 'Object Properties' section, in which                                                                                                                    
information about the image is displayed. The different tabs of this section are described below:  

 a) Setings: Options related to the display of the data are found here.  

b) Decription: Description of the projection, geometry, extent, values and size of the data selected.  

c) Legend: Displays the legend style of the data  

d) History: Maintains a log of all the operations and changes carried out on this layer.  

e) Attributes: This lists out the attributes of the selected data layer. 

5)SAGA cannot handle multi-band imagery. The layers have to be viewed individually. Therefore for every 
band combination, a false colour composite must be created as a separate image, or must overwrite a previous 
image. 

6) Click on the ' Zoom ' button  and then click and drag on the map to zoom in to a particular area (Alternately, 
we may use the mouse scroll wheel to zoom in and out). Zoom to the pixel level where every pixel can be easily 
distinguished from its neighbour. 

7)In the Object Properties section, under ‘ Settings ’ tab there will be a field titled ' Show Cell Values ' . Click 
on the check box next to it, and click on the ' Apply ' button below. 

 

8) To move around the map click on the   ' Pan ' button and then click and drag the map.  The cell values can 
also be viewed as a table/spreadsheet. Click on the Attributes tab and then select the  ' Action ' cursor form the 
Toolbar. Click and drag on the map. A rectangle will be drawn out which will encompass a few pixels.   

9) The current colour ramp of the layers is ‘greyscale’. We may assign a different colour ramp by clicking on 
the  ' Settings ' tab. Under the heading ' Graduated Color ' is the entry ' Colors '. Next to this is the current colour 
ramp which looks like this → . Select it and then click on the  button which appears on its right.   
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10) A Colors window appears, having 3 primary colour ramps which we can use to create our ramp. However, 
for now we will use a preset colour ramp. Click on 'Presets ' and select ' Rainbow ' from the Preset Selection 
List and click ‘ OK ’. Click ' Okay '. The settings of the layer will now look like this: 

11) Click on the ' Apply ' button located just above the ' Settings ' tab. The image will now have the values 
colored according to the rainbow sequence, with blue for the lowest and red for the highest values. 

12) Click on the  ' Description ' tab to view more information about the layer.Under ' Projection ' is given the 
projection parameters. Our image uses the WGS 84 Geographic Coordinate System. The identification code is 
EPSG 4326. 

Exercise 

1) SAGA stands for………………………………………………………………. 
2) What is Pixel? 

Conclusion: 

 

Video link: 

https://youtu.be/cdvncxRBu1I 

 

 

 

 

 

https://youtu.be/cdvncxRBu1I
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Lesson-8: Filtering of satellite image in SAGA software 

Objective: To remove the noise from an image, making it fit for analysis and interpretation.  

Software: SAGA (6.4.0) 

Image filtering is changing the appearance of an image by altering the colors of the pixels. Increasing the 

contrast as well as adding a variety of special effects to images is some of the results of applying filters.In 

image processing filters are mainly used to suppress either the high frequencies in the image, i.e. smoothing the 

image, or the low frequencies, i.e. enhancing or detecting edges in the image. An image can be filtered either in 

the frequency or in the spatial domain. 

Work flow: 

1. Open the Saga 6.4.0 software 

2. Import the satellite image  

3. Go to geoprocessing menu 

4. Click on “Grid”, then select “Grid collection” and then“filter” 

5. Select Grid system and grid  

6. Set the output filtered grid as “create” 

7. Set the kernel type and kernel radius. 

8. Click on “Okay” 

9. Check the original and filtered image after completing the process. 

KernalRadius: The radius describes the size of the kernel window. The value 1 represents akernel size of 3x3 

pixels. The value 2 represents 5x5 and so on. For now we will use thevalue 1. 
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Exercise:  

1. What are the different types of filters? 

2. Why filter is used? 

 

Conclusions:  

Video Link: 

https://youtu.be/LGkJepRWNi0 

 

 

 

 

 

 

 

https://youtu.be/LGkJepRWNi0
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Practical 9: Image preprocessing: Layer stacking, Mosaicing and subsetting of 
Multispectral images in Saga software 

Objective: To create stack layer,mosaic two satellite images and then subset it  

Software:Saga 6.4.0 

Data requirement:Corrected (Atmospheric and radiometric correction) Satellite data  

Layer stacking of Multispectral images 

Layer stack: Layer stacking is a process for combining multiple images into a single image. 

Work flow: 

1) Open Saga 6.4.0 software 

2) Import the multi band satellite data  

3) Go to geoprocessing menu 

4) Click on “Grid”, then select “Grid collection”. Next click on “create a grid collection” 
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5) Select Grid system and Objects  

 

6) Click “Okay” 

7) Check the output stacked image and go for false colour composite  

 

Mosaicking of Multispectral images 

Mosaicking:The syudy area in which we are interested may span several images file.It is necessary to combine 
the images to create one large file.This is called Mosaicking. 

Work flow: 

1) Open Saga 6.4.0 software 

2) Import two tiles of satellite image  

3) Go to geoprocessing menu 

4) Click on “Grid”, then select “Grid system”. Next click on “Mosaicking” 

5) Select Objects 

6) Set the “resampling” method and “target grid system” 

7) Click on “Okay” 

8) Check the output merged image layer 
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Subsetting of Multispectral images 

Subsetting: Subsetting refers to breaking out a portion of a large file into one or more smallerfiles.It is helpful 
to reduce the size of the image file to include only the area of interest(AOI). 

Work flow: 

1) Open Saga 6.4.0 software 

2) Import two tiles of satellite image  

3) Go to geoprocessing menu 

4) Click on “Grid”, then select “Grid system”. Next click on “Clip grid” 
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5) Select “Grid system” and object 

6) Set the “Extent”  

7) Click on “Okay” 

8) Check the output subset image layer 

Exercise:  

1) AOI  stands for………………………………………………….. 

2) Write Short notes on the following topics: 

 a) Subsetting 
 b) Mosaicking 
 c) Image Enhancement 

3)Which of the following is used to extract features and their attributes from one layer using a polygon from 
another as the boundary of the output?  

a)Join  

b) Merge 

c) Union  

d) Clip 

 

Conclusion: 

Video Link: 

https://youtu.be/LspsoYyK5oM 

 

 

 

 

 

 

 

https://youtu.be/LspsoYyK5oM
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Lesson-10: Visual image interpretation: False colour composite 

Objective:To identify features and extract the useful information from the remotely sensed images based on 
the visual interpretation techniques. 

Software:SAGA GIS (6.4.0) 

Image interpretation is a powerful technique enable us to identify and distinguish various features in remote 

sensing images/Aerial photos and allows gaining the knowledge and information about them. Analysis of 

remote sensing image often involves identification of various features such as forest cover, water bodies, urban 

settlement, agriculture and range land etc. These features are identified by the way they reflect or emit 

radiations and also by their association and location. These radiations are measured by satellite/Aerial sensors 

and ultimately depicted in the form of satellite image or aerial photo. Identifying individual features from 

images is a key to interpretation and information extraction. Recognizing differences between feature and its 

background are generally based on some of these visual interpretation keys generally known visual 

interpretation elements , viz., shape, size, pattern, tone, texture, shadow and association.  

Image Interpretation using visual elements of Interpretation  

Different elements of visual image interpretation 

Tone: The dictionary definition of tone is the particular quality of brightness, deepness, or hue of a shade of a 

colour. Therefore tone refers to relative brightness or colour of a feature on an image. The tonal variation makes 

it easier to differentiate between various features on an image. Shapes, patterns and textures on an image are 

identifiable mainly due tonal variation.   

Shape: General form, structure, or outline of an object is called as shape. It is an important tool for photo 

interpretation. Urban or agriculture features have straight edge shape, whereas forest and other natural features 

have irregular shape. The shapes of objects on photographs are vertical view of the objects. It is sometimes very 

difficult to identify elements on ground from their vertical view. Shape of any objects act as a tool in 

identification of structure, composition and function of the object. 

 

Size: Scale of the photograph determines the size of objects on the photographs. Assessment of absolute size of 

the objects and their relative size to other object aids in photo interpretation. For instance, it helps in 

determining if the object is small pond or a large lake. It also helps in differentiating smaller roads from larger 

highways, and also helps in distinguishing between smaller tributaries from large river. By quick estimation of 

size of the object can drive to interpretation to a suitable result easily. 

 

Pattern: Pattern is an important clue for identification of features. Smallest and significant patterns can be 

captured with the help of aerial photograph. There can be some natural and some cultural pattern and some are 
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resulted because of interaction of man and nature. Pattern is nothing but spatial arrangement of phenomena on 

the earth surface. This spatial arrangement is used in the identification of objects. 

 

Texture: Texture is defined in terms of “smoothness” and “roughness”. The amount of change in photograph 

causes smoothness or roughness. Object, which has less variation, appears smooth and object, which has more 

variation, appears rough. Generally smother surface has lighter tone in the photograph. Rough texture like tall 

grasses and shrubs are of dark tone 

 

Shadow:Size and shape of any object can be assumed by their shadow. Therefore, it is also useful in 

interpretation. It can give a clue related to the profile and relative height of an object or targets that 

helps in easier identification of objects. It is also very useful most particularly in radar imagery for 

identification of topography and landforms on the earth surface. However, some useful information is 

also lost because of shadows as objects are very less detectable in the area of influence of shadow.. 
 

Color:When any object reflects light in a particular wavelength they are showing different shades of colour. For 

instance, naturally, vegetation appears green because they reflect a larger part of green light than the other 

colour like blue or red. Colour is an important tool for photo interpretation because, it is easier for humans to 

differentiate different colour than different shades of grey.. 

 

Association: Association is occurrence of certain feature in relation with other. Certain features are not directly 

identifiable by its appearance in an image but could be interpreted easily according to its relationship with the 

surroundings. For example association of boats with water, Aircraft with runway, playground with school etc. 

Natural colour composite: A natural or true color composite is an image displaying a combination of the 

visible red, green and blue bands to the corresponding red, green and blue channels on the computer display. 

The resulting composite resembles what would be observed naturally by the human eye: vegetation appears 

green, water dark is blue to black and bare ground and impervious surfaces appear light gray and brown. Many 

people prefer true color composites, as colors appear natural to our eyes, but often subtle differences in features 

are difficult to recognize. Natural color images can be low in contrast and somewhat hazy due the scattering of 

blue light by the atmosphere. 

False colour composite (FCC): False color images are a representation of a multispectral image 

produced using any bands other than visible red, green and blue as the red, green and blue components of the 

display. False color composites allow us to visualize wavelengths that the human eye can not see (i.e. near-

infrared and beyond). Using bands such as near infrared highlights the spectral differences and often increases 

the interpretability of the data. There are many different false colored composites that can be used to highlight 
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different features. See the heading below for more information about common band combinations for false color 

composites. 

Conventional False colour composite 

Band combination- NIR- Red- Green: Vegetation looks red and water looks black 

Work flow: 

1) Open Saga 6.4.0 software 

2) Import multiband satellite image  

3) Go to geoprocessing menu 

4) Select “Visualization” and then click on “Grid” 

5) Choose “RGB Composite” 

 

6) Set the grid system 

7) Select NIR, Red and Green band in the place of Red, Green and Blue respectively. 

 



Geoinformatics,nano-technology and precision farming 
 

37 | P a g e  
 

8) Click “Okay” 

9) Check the RGB composite and interpret the land use features 

 

 

Exercise:  

3) What is False color composite? 
4) What is Natual color composite? 
5) What are the 3 true colors? 

Conclusion: 

 

 

Video link:  

Visual image interpretation:https://youtu.be/WFBqWWoE45w 

False colour composite:https://youtu.be/zfkeqideeCk 

 

 

https://youtu.be/WFBqWWoE45w
https://youtu.be/zfkeqideeCk
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Practical 11:  Spectral profile generation and vegetation indices 

Objective:To determine the spectral characteristics of determine the spectral characteristics of different land 

use features. 

Software:SAGA 6.4.0 

Data requirement : Satellite Data, vector (polygon) layer, Spread Sheet software (MS Excel) 

Spectral reflectance curve shows the relationship of electromagnetic spectrum(distribution of the continuum 

of radient energies plotted either as a function of wavelength or of frequency)with the associated percent 

reflectance for any given material.It is plotted  in a chart that represents wavelength in horizontal axis and 

percent reflectance in the vertical axis. 

 

 

Work flow: 

1) Open Saga 6.4.0 software 

2) Import multiband satellite image  

3) Go to geoprocessing menu 

4) Select “Shape” and then click on “Grid”. Next select “Grid values” 

5) Choose “Grid statistics for polygons” 

6) Set Grid system, grid, Polygon layer and statistics. 

7) Click on “Okay” 

8) Right click on the output file present in the data panel 

9) Select “Attributes” and select “Save attribute as” 
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10) Save the output file as “.csv” file 

11) Prepare the graph containing spectral reflectance of the polygons 
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Vegetation indices 

Objective: commonly used to indicate the amount and health of vegetation in an image,and to differentiate 

vegetation,soil and water in forest. 

The vegetation index is an indicator that is calculated as a result of operations with different spectral ranges of 

remote sensing data and is related to the vegetation parameters in a particular pixel of the image. The 

effectiveness of vegetation indices is determined by the characteristics of reflection. The calculation of most of 

the vegetation indices is based on two the most stable sections of the curve spectral reflectance of plants. 

1) NDVI - normalized difference vegetation index. NDVI is an image transformation technique used to 

monitor the vegetation condition.NDVI is a combination of addition,subtraction and division.The 

index for NDVI of a Landsat TM image is (band4-band3)/(band4+band3). 

 

 

 

 

 

 

 

 

 

Pixel value in the resultant image varies between -1.0 and +1.0.NDVI of an area containing a dense vegetation 

canopy will tend to positive values (say 0.3 to 0.8) while clouds,water and snow fields will be characterized by 

negative values of this index.Other targets show values near 0;e.g.,soils generally show values between 0.1 and 

0.2.Very high positive values(say 0.6 to 0.8)indicate healthy vegetation,while value-range 0.3 to 0.6 may be 

considered as stressed vegetation.However,this may vary from species to species and season to season. 
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2) Soil-adjusted vegetation index(SAVI): Empirically derived NDVI products have been shown to be 
unstable, varying with soil colour, soil moisture, and saturation effects from high density vegetation. 

SAVI = (1+ L)( NIR-RED)/(NIR+RED+L) 

where L is a canopy background adjustment factor. An L value of 0.5 in reflectance space was found to 
minimize soil brightness variations and eliminate the need for additional calibration for different soils. The 
transformation was found to nearly eliminate soil-induced variations in vegetation indices. 

 

 
3) Normalised difference Water Index :Application include forest canopy strssanalysis,leaf area index 

studies in densely foliated vegetation,plant productivity modeling and fire susceptibility studies. 
 

(NIR – MidIR) /( NIR + MidIR) 
This also used: (Green – NIR) / (Green + NIR) 

 

 

How to calculate NDVI 

Objective:To compute NDVI in SAGA software 

Software: SAGA 6.4.0 

Data requirement:Multiband satellite data 

Workflow:  

1) Open Saga 6.4.0 software 

2) Import multiband satellite image  

3) Go to geoprocessing menu 

4) Select “Imagery” and then click on “Vegetation indices”. Next select “Vegetation indices (slope 

based)” 

https://en.wikipedia.org/wiki/NDVI
https://en.wikipedia.org/wiki/Soil_moisture
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5) Set Grid system. 

6) Select Red and NIR band in proper place 

7) Set the “Normalized Difference Vegetation Index” as “Create” 

8) Click on “Okay” 

9) Check the output NDVI layer  

 

 

Exercise: 

1)How do you calculate NDVI? 
2)What is the range of NDVI? 
3)What is spectral profile? 
4)Which of the band has the highest reflectance for Vegetation? 
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Conclusion: 
 

 

 

 

Video link: 

NDVI: https://youtu.be/WIP1genuoVo 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://youtu.be/WIP1genuoVo
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Lesson-12:  Unsupervised classification 

Objective: To create a land use and land cover map of a region by the unsupervised classification method using 

SAGA. 

Software: SAGA GIS 

Data requirement :Satellite image (Layer stacking) 

To create a land use and land cover map of an area, we have to assign corresponding land use and land cover 

type to every pixel in the satellite imagery that exist at the time of acquisition. This is done based on the Digital 

Number (DN) values of the pixel which in turn represent the spectral properties of the ground surface. This 

assigning of classes to pixels in an image is called ‘ Image classification’.  

There are two broad types of image classification exists – ‘ Supervised classification ’ and ‘ Unsupervised 

classification ’.  

In unsupervised classification, the algorithm analyzes all the bands of the image and pick out the clusters of 

pixels having similar values without the user intervention. The clusters are then assigned to their classes at the 

user’s discretion. Therefore, this method generally applied to the regions, where we don’t have any knowledge 

and information about land cover type.  

Workflow: 

1) Open SAGA software 

2) Open image data 

3) Geoprocessing  

4) Imagery 

5) Classification 

6) Unsupervised 

7) Select algorithm 

8) Select Grid system and objects 

9) Select the number of clusters 

10) Click on “Okay” 

11) Open the properties panel for the clusters 

12) Select table and open look up table 

13) Check the classes by changing the colours and values 

14) Change the name of the class 

15) Save the look up table 

16) Apply 
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17) Geoprocessing 

18) Grid 

19) Value 

20) Combine classes 

21) Choose the grid system and grid 

22) Combine the classes and click okay 

23) Okay 

24) Area calculation for the region of interest 

Detailed Methodology: 

• Load the LandSat images into SAGA by clicking on the  ‘ Load File ’ button or via File → Grid → 
Load . Select the ‘ Kolkata_liss3_2010.tif ’ image. This will import the image into SAGA.   

• We will change the composite band combination to True Color by using settings tab. Select 
‘‘Kolkata_liss3_2010.tif ’’ under Data tab. In settings, navigate to‘Colors’ section> Type RGB 
composite >Scaling Mode>Linear >RGB composite > Red-2.0000,Green-1.0000,Blue-0.0000>Apply  

 

 

 

• Now we will classify the image using Geoprocessing → Imagery → Classification → Unsupervised → 
ISODATA(Iterative Self-Organizing Data Analysis Technique)  Clustering for Grids . The module 
window options are explained below. 

• Grid System: This is grid system of the image to be classified. Select it from the drop down menu.  
• >>Features: These are the input grid layers that will be used in the classification. Click on the  

buttonand select the LandSat layer/s and click on the  button and click on ‘Okay’.  
• <<Clusters: This is the output option for the clustered image. To create a new image we keep it as ‘ 

[create] ’ . If we are running the cluster analysis for the second time and want to overwrite an image 
then select the image to be overwritten from the dropdown menu. table by selecting it from the 
dropdown menu. 

• <<Statistics: This creates a table with the statistics of the band layers and the clusters. By default it is 
set as‘ [ create ] ’ but we can overwrite an existing 
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• On clicking ‘ Okay ’, the ISODATA cluster analysis will start and will keep reiterating the search.You 
can see the progress on the left side of the status bar located at the bottom of SAGA GUI. 

 
• The classified image titled ‘ Clusters ’ is placed in the LandSat image grid system. Double click on it 

to open in the ‘ TrueColour Composite ’ map list.    
 

• This newly created cluster map splits the image area into homogenous land cover  segments. We now 
have to assign each cluster to its land cover class. 

 
• Before doing that we have to assign a unique number to each land cover class. We will use a simple 

9class classification.  
 

• 8)Now turn on and off the cluster layer in the Map window. You will see that the clusters take the 
shape of some land features. This way we can identify the clusters based on their shape, location and 
image pixel values. 

 
• Select the ‘ Clusters ’ layer from the data list and click on the Legendtab. This will display the 

different class numbers and their associated colour. To check which cluster a pixel belongs to, just 
mouse over the pixel and look at the Status Bar at the bottom of the SAGA window. This displays the ‘ 
Z value ’ of the pixel. In this case the Z value is the class number.     

 
• 10)We will start assigning class numbers to the clusters by selecting the layer and then accessing the  

Settingtab. Click the….button under ‘ Table ’ to open the lookup table. This will give the clusters 
information with five fields: COLOUR , NAME , DESCRIPTION, MINIMUM and MAXIMUM. 

 
• The color of a cluster can be changed by clicking on it and choosing a color from the palette. The 

MINIMUM and MAXIMUM fields indicate the cluster number and will have the same value in this 
table. The numbering of the clusters starts from 1. Therefore, C lass 1 would be numbered 1, C lass 2 
would be numbered 2, and so on 

 
• Identifying classes and the land cover they represent can become difficult when looking at the cluster 

map with all its classes. To make it easier, we will handle them one at a time.    
 

• Change the MINIMUM and MAXIMUM field values of all the rows by clicking on the cells and 
replacing them with the value ‘-1’. Mark the first row MINIMUM and MAXIMUM value as ‘1’ and 
change the color to ‘Yellow or any other bright color’ to click ‘ Okay ’. Click on ‘ Apply ’ below. This 
will make the classes marked with ‘-1’ invisible.  
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• Turn the cluster layer off to view the satellite image below it. Identify the type of land covered by this 
cluster using the false color or true color composites. For example, let’s look at the first cluster.   

 
• We see that the cluster covers ‘River’ land cover. Considering the land cover type it would probably 

fall under the builtup category. So we mark in the NAME column as ‘River’ and color to ‘builtup’.  
 

• Let’s take the Class 2 . In ‘Lookup Table’ change the MINIMUM and MAXIMUM field values to its 
original value, i.e., ‘2’, color to ‘Yellow’ and for Class 1 to ‘ - 1 ’. This will made only Class 2 is 
visible. Now we zoom to more prominent details by keeping either false color or true color composites 
to identify the land cover. 

 
• Go to the next cluster below and change its MINIMUM and MAXIMUM value to its original value 

(this will make it visible). Change its colour to ‘Yellow or some other bright color’. Click ‘ Okay ’ and 
then ‘ Apply ’.  The next cluster will now be visible.   

 
• Repeat the steps 15 to 18 till all the clusters have been assigned a class number.   

 
• Once we are done with this, make sure that the MINIMUM and MAXIMUM columns have the 

original values instead of ‘-1’. Click on the ‘ Save ’ button in the lookup table and save this table as a 
text file in a convenient location. Use an explicit name like Lookup_ Table ’ which can be easily 
identified. 
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• Open the ‘Combine Classes’ module via Geoprocessing → Grid → Values → Combine Classes . 
Select the grid system as per ‘Cluster’ grid system, ‘Grid’ as ‘Clusters’ and ‘Output’ as ‘Create’ 

 
• Click the….button in the ‘Classes’ entry under ‘Options’ section. Now you can see class names under 

two columns. In the right column select the first entry of respective and use class in drop down menu 
as shown below. Click ‘okay’ in ‘Classes’ window and ‘Okay’ in ‘Combine Classes. 

 
 
 

• Now you can see the combine classes’ grid under ‘Data’ tab in ‘Manager’. Change the. Name of 
‘Clusters [Combine Classes]’ to ‘ Unsupervised’ . Open the unsupervised classification image on true 
color or false composite for comparison. ‘Save As’ the project with proper name and save other 
changed datasets before closing the SAGA GIS.  
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• For area calculation Go to geoprocessing >> Shape >> Grid>> values>> Grid class area for polygon. 
Then set the grid system and grid. Select the polygon layer. Click on okay 

• Save the output file containing the class area as “.csv”. 
 

Exercise:  
 
 

1) DN stands for……………………………………………………………………. 
2) ISODATA stands for…………………………………………………………… 
3) Unsupervised training  is controlled by ……………………………. 
4) Unsupervised classification requires- 

a) prior knowledge of the region 
b) does not require prior knowledge of the region 
c) training data set to classify the image 
 
 
 
 
 
 

Conclusion: 

 

 

 

 

Video link: 

https://youtu.be/-uX58AOhnOM 

 

 

 

 

 

 

 

 

 

https://youtu.be/-uX58AOhnOM
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Lesson-13:  Supervised classification 

Objective: To create a land use and land cover map of a region by the S upervised classification method using 
SAGA.  

Software: SAGA GIS 

Data requirement :Satellite image (Layer stacking) 

In supervised classification, the user will select a group of pixels belongs to a particular land use / land cover 
known as training areas or training sites. Based on the pixel values in the training areas the software will create 
spectral signatures and the statistical information like range, mean, variance etc., of all classes in relation to all 
input bands. This information has been used to categorize each and every pixel in the image into corresponding 
land use and land cover class based on the classification algorithm used. Maximum Likelihood (ML) , 
Minimum Distance to Mean (MDM) and Parallelepiped classification algorithms are most commonly used for 
supervised classification. 

Since, the supervised classification method involves selection of training areas, the user should have a good idea 
about different land cover classes existing in the study area. This knowledge can be acquired through field 
verification and other ancillary data. 

Workflow: 

1) Open SAGA software 

2) Open image data 

3) Geoprocessing  

4) Imagery 

5) Classification 

6) Supervised classification for grids 

7) Select Grid system and objects 

8) Select training class and class indentifier 

9) Select algorithm 

10) Click on “Okay” 

11) Open the properties panel for the classified output 

12) Select table and open look up table 

13) Check the classes by changing the colours and values 

14) Change the name of the class 

15) Save the look up table 

16) Apply 

17) Okay 

18) Area calculation for the region of interest 

 



Geoinformatics,nano-technology and precision farming 
 

51 | P a g e  
 

 

Detailed Methodology: 

• Open SAGA Interface → Load the LandSat images into SAGA by clicking on the  ‘ Load File ’ button 
or via ‘ File → Grid → Load ’. Select the ‘ band_stack.tif ’ images and click ‘ Open ’. This will 
import the image into SAGA.  

• We will change the composite band combination to True Color by using settings tab. Select 
‘‘band_stack.tif ’’ under Data tab. In settings, navigate to ‘Colors’ section, select the band 
combinations as shown in below figure and Click on ‘Apply’. 

 
 

• Similarly, visualize the study area by using following false color band combination and try to identify 
the land use and land cover in the false color composite by using visual interpretation elements and 
make a note. 

• *Task: Use this false color composite to learn which land cover / land use types are represented 
by which colors in different band combinations 
 

• In SAGA, the sample collection is done by using shapefile polygons.Export Shape file from QGIS 
software. 

• Open QGIS > Go to SCP Dock > Training input >Create a new training input > Select folder >create  a 
new .scp file >  Now in SCP: ROI creation panel click on new shp. ROI means Region of Interest. 

• Now as per your knowledge of the location zoom in and create a polygon. We are creating polygon 
because it will take pixels of same colour with slightly difference in the value. Right click to end the 
polygon > Give Macroclass name and class name > click on Save temporary ROI . 

• The roi is added to the signature list > Same signature select all >click on merged highlighted signature 
> 

• Then create a merged class > all other class deleted > Then next signature class create using ROI 
>Same process do Merged and delete. 

• Save this signature list in the same folder, and create new ROI’s for different classes. You can also 

change the color. Within same class you can have different Macroclass so that you can classify 

precisely 

• SCP tool > Go to Basic tools > Export signature > Export as .shp file > Go to Destination folder  

• Open again SAGA GIS software > File >Load > shape file>Go to Destination folder > Open 
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• A polygon named ‘ Sample_signature’ will be created and placed in the ‘ Data ’ list under the Shapes 
. Add this polygon layer to the map (False color composite) on which you would like to create the 
sample polygons by double clicking on the ‘Sample_signature ’ shape file  → Now select ‘Cossaipur’ 
from the popup window i.e., ‘ Add layer to selected Map ’  → ‘ OK. 
 

• Once you are done with the signature collection, now you are ready to run Supervised classification 
module. Open it via ‘ Geoprocessing → Imgery → Classification → Supervised Classification for 
Grids ’ module. Set the values for Grid system , Grids , Training Areas and Class Identifiers as shown 
below. 
 
a. The ‘ Grid system ’  select entry will be the grid system of our input data set. For the  
b. >> ’Feature ’, click on the  button to the right of the field. In the dialogue popup window, we 

select the Raster and click on the  button. This will transfer the layers to the right which indicates 
that they will be used by the module. Click ‘ Okay ’ . 

 ‘>>Classification ’ as ‘[ Create ]’. The Quality option allows us to create an image which describes 
the quality of the classification for every pixel. The image values vary with the type of classification, 
here will select ‘ [ not set ]’.   
c.  ‘>>Training Areas ’ input is the shapefile containing all the signature shapes. Set it as ‘ 
Sample_signature’ .   

d. The ‘ Class Identifier ’ is the field with which we differentiate the classes. The classes will be 
named according to this field. Set it as ‘ MC_ID ’ or ‘ Name ’. By using this text field we can easily identify 
and relate the sample area description with the class.   

e. Set the Method option as ‘ maximum likelihood ’ and probability Threshold 90  

f. Click on ‘ Okay ’ to proceed for maximum likelihood supervised classification 

 

• We can assign colours and class names via the lookup table. Select the image from the list and open 
the lookup table by clicking the  button via the  tab. 
 

• The lookup table will open with 5 columns - COLOUR, NAME, DESCRIPTION, MINIIMUM, 
and MAXIMUM. Click on the color box and select a color from the palette or create your own. Click 
on ‘ Okay ’and then ‘ Apply ’ in the  tab. 
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• We will now create a map of this image by opening it in a new map window. Select the map from the  
tab and then click ‘ Show Print Layout ’  button in the toolbar located below the Main Menu . This 
will open a window with the map layout. 

• Change the name of the map via the  tab. In the Name field type ‘ Land - Cover Classes ’, press Enter 
, and then click Apply .    

• The fields of the  tab are different for the map and for the image. Selecting on the map will enable you 
to add or remove map features like scale and legend. 

• To adjust the map extent, or to represent only a particular region on the map, we must zoom in and out 
using the Map window instead of the Map Layout window. This is linked to the Print layout window 
will automatically adjust the zoom to the Map window extent.  

• To view the final map, click the ‘ Print Preview ‘ button before click on print. 
• We can save this map either by printing as a PDF file or by exporting it as an image ( Right Click → 

Save as Image ). 
• Use a suitable name for the map and format, then click ‘ Okay ’. In the next window that opens, some 

parameters will be given regarding the map. Uncheck ‘ SaveGeoreference ’ and ‘ Save KML (Keyhole 
Markup Language)File ’ and leave the other parameters as the default values. Click ‘ Okay ’. The 
image and the legend get saved as separate files.  The saved map will look like this: 

• For area calculation Go to geoprocessing >> Shape >> Grid>> values>> Grid class area for polygon. 
Then set the grid system and grid. Select the polygon layer. Click on okay 

• Save the output file containing the class area as “.csv”. 
 

 
 

Exercise:  

1)Which one of the following helps to identify the objects on the earth surface? 

a)Radiometric error 
b)signature 
c)Atmosphric window 
 
2)KML stands for………………………………………………………………………………………….. 
3)Supervised training is closely controlled by ………………………………………… 
4)MDM stands for……………………………………. 
5)Supervised classification classifies image based on – 
  a) spectral class 
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  b) information class 
  c) both 

 
Conclusion: 

Video link: https://youtu.be/2uPVfM0-O18 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://youtu.be/2uPVfM0-O18
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Practical 14:  Crop stress (biotic/abiotic) monitoring using geospatial technology 

Geospatial technology is a rapidly growing and changing field.The term geospatial technology (GST) refers to 
geographical information systems(GIS),global positing systems(GPS),remote sensing(RS),all emerging 
technologies that assist the user in the collection,analysis,and interpretation of spatial data 

Biotic Stress is stress that occurs as a result of damage done to plants by other living organisms, such as 
bacteria, viruses, fungi, parasites, beneficial and harmful insects, weeds, and cultivated or native plants.  

Abiotic stress is defined as the negative impact of non-living factors on the living organisms in a specific 
environment. 

Effect of Biotic and Abiotic Stress in Agriculture 

Biotic stress also impacts horticultural plant health and natural habitats ecology. It also has dramatic changes in 
the host recipient. Plants are exposed to many stress factors, such as drought, high salinity or pathogens, which 
reduce the yield of the cultivated plants or affect the quality of the harvested products. Arabidopsis thaliana is 
often used as a model plant to study the responses of plants to different sources of stress ( Mittler, Ron, 2006). 
Whereas a biotic stress would include such living disturbances as fungi or harmful insects. 

 Abiotic stress factors, or stressors, are naturally occurring, often intangible, factors such as intense sunlight or 
wind that may cause harm to the plants and animals in the area affected.Abiotic stress is essentially 
unavoidable. Abiotic stress affects animals, but plants are especially dependent on environmental factors, so it is 
particularly constraining. Abiotic stress is the most harmful factor concerning the growth and productivity of 
crops worldwide. Abiotic stress comes in many forms. The most common of the stressors are the easiest for 
people to identify, but there are many other, less recognizable abiotic stress factors which affect environments 
constantly.  

The most basic stressors include:   

1  High winds 
2  Extreme temperatures 
3  Drought 
4.Pest and disease 
5.flood 
6.Salinity 
 

Application of Remote Sensing for Monitoring Biotic and Abiotic Stress 
 
Hyperspectral remote sensing is one of the advanced and effective techniques in disease monitoring and 
mapping. However, the difficulty in discriminating a disease from common nutrient stresses largely hampers the 
practical use of this technique. This is because some common nutrient stresses such as the shortage or overuse 
of nitrogen or water could have similar variations of biochemical properties and plant morphology, and 
therefore result in similar spectral responses. However, for the remedial procedures for stressed crops, there is a 
significant difference between disease and nutrient stresses. For example, applying fungicide to water-stressed 
crops would lead to a disastrous outcome. Therefore, to discriminate yellow rust from common nutrient stresses 
is of practical importance to crop growers or landowners. The traditional ground-based survey method requires 
high labor cost and produces low efficiency. Thus, it is unfeasible for large area. Fortunately, remote sensing 
technology can provide spatial distribution information of diseases and pests over a large area with relatively 
low cost. The presence of diseases or insect feedings on plants or canopy surface causes changes in pigment, 
chemical concentrations, cell structure, nutrient, water uptake, and gas exchange. These changes result in 
differences in color and temperature of the canopy, and affect canopy reflectance characteristics, which can be 
detectable by remote sensing (Raikes and Burpee 1998). Therefore, remote sensing provides a harmless, rapid, 
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and cost-effective means of identifying and quantifying crop stress from differences in the spectral 
characteristics of canopy surfaces affected by biotic and abiotic stress agents. 
 

Objective: It enables the farmer to implement timely interventions that ensure optimal yields at the end of the 
season. 

Data requirement : 1) weather and crop data 2) Crop yield and management data 3) GPS data 4) Satellite 
Data  

Software: SAGA GIS, QGIS 

Methodology: 

1) Data used Collection of weather and crop data The daily weather data used in the study such as 
temperature, precipitation, sunshine hours, relative humidity etc from the Agrometeorological 
observatory  

2) Crop yield and management data (sowing/harvest etc.) related to crop were collected from Agriculture 
farm.  

3) Software used QGIS,SAGA GIS was used for processing of remote sensing images. In this particular 
approach, QGIS GIS software was also applied so as to digitize the field boundary. 

4) Ground Truth Ground truth finds noteworthy applications in remote sensing and is a pre-requisite for 
image classification. The ground truth data intended for supervised classification were collected from 
field surveys r with the help of a GPS. 

5)  At the same time, a broad map showing positions of few ground control points (GCPs) was generated. 
Crop fields could be easily discriminated by identifying the location of fields with the help of latitude 
and longitude and using the generated GCPs.  

6) Cloud free LANDSAT-ETM+/TM images were collected. The data is being currently provided by 
USGS and is available free of cost at the website (http:// glovis.usgs.gov/) for download.  
a) Digitization of the boundary 
displaying of MTL file of a particular satellite image in RGB and overlaying the vector file on it. The 
vector file was exported as Region of Interest (RoI); after which subset of satellite image was created 
via RoI The subset of LANDSAT image covering entire area. and was further used for identification. 
b) Atmospheric correction and gap filling Atmospheric correction was performed in order to get rid 
of the atmospheric disturbances/noise so that the exact reflectivity of an entity in the absence of 
atmosphere can be recognized.  
c) Generation of NDVI NDVI images district for each date were generated using red and NIR bands. 
NDVI images for each date were obtained through band math module of SAGA software after 
correcting the images atmospherically. 

d) Classification of image and crop discrimination The physical condition of crop can be monitored using 
both ground truth data and its spectral property. Image classification using maximum likelihood classifier was 
carried out and ROIs were created over different objects and the entire image was classified into separate 
classes based on the spectral signature of each entity.Supervised classification methods are based on knowledge 
of the study area which comprises of various types of inputs derived through ground truth information.  

  e) Generation of normal growth profile of crop Growth and decay of crop canopy can be characterized by 
temporal plot of spectral indices. A mathematical function fits to the temporal crop growth profile and forms a 
representation of crop growth. The peak of this profile corresponds to peak of vegetation cover of the crop. 
NDVI. Growth profile of wheat has been developed using vegetation indices generated from satellite data. 
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f) Discrimination of healthy and stressed cropThe discrimination of crop was carried out by building crop 
mask on the classified image for a particular year. crop mask file consists of wheat pixels only with outside 
pixels “masked off’; enabling selection of crop pixels with their NDVI values from rest of the classes. The 
NDVI values of crop in each image were compared with the expected wheat NDVI values for that particular 
date, as derived from the normal growth profile of crop. After comparison of different crop pixels, colour 
mapping (density slice) was applied in order to classify the crop pixels into stressed and healthy wheat 
categories. The pixels having NDVI value more than the expected NDVI value (normal NDVI value on that 
particular date) were designated as healthy pixels, while pixels with lower NDVI values were designated as 
stressed pixels.  

 g)Thematic maps discriminating infected (red colour) and healthy (green colour) wheat crop were prepared 
Identification of yellow rust affected areas It has been reviewed from various literature sources that yellow rust 
was the only prominent factor causing stress in crop. 

The infected vegetation was reclassified into three categories viz. most severely affected, moderately affected 
and least severely affected depending upon the Three severity classes were categorized based on the reduction 
in NDVI values; i.e. by 20 %, 40% and more than 40%. The maps were generated showing most severely 
affected crop in red, moderately affected vegetation in magenta and least severely affected wheat in yellow 
colour. Spread index was also calculated by summing up the above referred categories. 

1) How geospatial technologies can help in farming? 
2) Which of the following is an example of abiotic stress? 
3) GST stands for…………………………………… 
 
Conclusion: 

 

 

  

Video link : 
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Practical-15:  Fertilizers recommendations based of VRT and STCR techniques 

Fertilizer is one of the costliest inputs in agriculture and the use of right amount of fertilizer is fundamental for 
farm profitability and environmental protection.  Imbalanced use of fertilizers by farmers not only reduces the 
yield of the crops but also deteriorate the quality of soil and water resources. To enhance farm profitability 
under different soil-climate conditions, it is necessary to have information on optimum fertilizer doses for every 
crops. For determining the optimum fertilizer doses, the most appropriate method is Soil Test Based Integrated 
Fertilizer Recommendation for different crop which are based on the soil test and crop response studies. High 
yielding, fertilizer responsive varieties of crop and high cost of fertilizers have necessitated the development of 
a quantitative basis for making fertilizer recommendations according to soil fertility status of field for obtaining 
economic yield.   
 
Soil test crop response (STCR) study based on soil test based fertilizer recommendation should be carried out 
to develop quantitative basis for calculating the profit maximizing dose of fertilizers based on soil test for any 
crop STCR approach is based on soil contribution and yield level is used for recommending fertilizer dose.   
 
STCR concept is more quantitative, precise and meaningful. Among various methods of fertilizer 
recommendation such as general recommended dose (GRD), soil test based recommendation, critical value 
approach, etc., the soil test crop response (STCR) approach for targeted yield is unique in indicating both soil 
test based fertilizer dose and the level of yield that can be achieved with good agronomic practices. 
 
 
Objectives of STCR  
 

• To study the relationship between soil test values for available N, P, K and yield response to important 
crops.  

• To derive yield targeting equations for important crops for making fertilizer recommendations.  
• To evaluate various soil test method for their suitability under field conditions.  
• To evaluate the extent to which fertilizer needs of crop can be reduced in relation with conjunctive use 

of organic manure 
 
 Concept of STCR  
 
ICAR established the AICRP on STCR in 1967 and the STCR concept was developed by Ramamoorthy in 
1987.   STCR approach is aiming at obtaining a basis for precise quantitative adjustment of fertilizer doses 
under varying soil test values and response for targeted levels of crop production.   STCR provides the 
relationship between a soil test value and crop yield.  These are tested in follow up verification by field trials to 
back up soil testing laboratories for their advisory purpose under specific soil, crop, and agro climatic 
conditions  
 
Methods of STCR  
 

 Gradient experiment: in this phase artificial soil fertility gradient is created at experiment site by 
following procedure: 

 
• Divided the experiment field into 3 or 4 equal strips according to size of field.  
• In 1st strip – no fertilization, 2nd strip -single fertilization, 3rd strip – double fertilization likely 

increasing fertilizer dose with increase in number of strips  
• Grow exhaustive crop like  maize, sorghum fodder crops.  
• Pre sowing and post harvest soil samples were collected from each strips and analysis. 
• Plant analysis after harvest of exhaustive crop 
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 Test crop experiment: after confirming the establishment of fertility gradients in the experiment 

field this phase of field experiment conducted with the following procedure: 
 

• Each strip is divided in number of plots which is equal to treatments  
• Initial soil sample is collected from each plot and analyzed  
• The experiment is layout as per statistical design   
• Test crop experiment is taken with different level of fertilizers  
• After maturity of crop to calculated yield from each plot  
• Soil and plant sample is collected from each plot and analyzed  
• Using the yield and nutrient uptake data, soil test values and applied fertilizer doses of treated 

and control plots, the basic data viz. nutrient requirement (kg/q), soil, fertilizer and organic 
manure efficiencies (%) for making fertilizer recommendation can be worked out. 
 

Target Yield Equation 
 

•  Liebig’s law of minimum is the basis of this concept. 
•  First advocated by established the theoretical basis and experimental proof for the fact that 

Liebig’s law of the minimum operates equally well for N, P and K.  
• Among the various methods of fertilizer recommendation, the one based on targeting is 

unique in the sense that this method not only indicates soil test based fertilizer dose but also 
the level of yield.  

• Targeted yield concept is a balance between applied nutrients and the available nutrients in 
the soil.  
 

Conditions for yield targeting equation 
• Used for similar soils of particular agro-eco region.  
• Maximum targets should not exceed 75-80% of  highest yield achieved for the crop  in the 

area.  
• Fertilizer N recommendations for legumes should be same as general dose of the crop of the 

area.  
• Adjustment equations must be made within experimental range of soil test values.  
•  If the targeted yield was achieved within ± 10 per cent variation,  then the equations are 

found to be valid. 
 

STCR Approach for Precision Agriculture: 
 

 Agricultural production system is an outcome of complex interaction of seed, soil, water, fertilizers 
and other agrochemicals. Therefore, judicious management of all the inputs is essential for 
sustainability of such a complex system  

 Under normal conditions, recommended soil sampling procedure is to take samples from portions of 
fields are no more than 20 acres in area  

 Grid soil sampling uses the same principles of soil sampling but increases the intensity of sampling  
 The goal of grid soil sampling is to generate a map of nutrient requirement called an application map 
 Application map is loaded into the computer mounted on variable rate fertilizer spreader  
 Computer uses the application map and GPS receiver to direct a product delivery controller that 

changes the amount and kind of fertilizer product according to application map  
 
 
                                   Variable Rate Technology (VRT) 
 
 

Variable-rate fertilizer application allows you to apply different rates of fertilizer in each part of the field. How 
you distribute fertilizer depends on the planned yield, soil fertility and factors that influence it. This might 
be topography, soil texture, electrical conductivity, as well as soil nutrients and moisture content. 
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Grid soil sampling and variable rate fertilizer applications are a part of the precision agriculture movement that 
has captured the interest of many farmers. Variable rate fertilization requires extra expense and effort plus the 
use of often unfamiliar technology. Global Positioning Systems (GPS) equipment and computer software are 
used to outline and grid the field into small manageable units or “cells” (usually 2.5 acres). Each grid cell is soil 
sampled and tested for pH and available nutrients. Fertilizer recommendations are made on each grid cell and 
the fertilizer is spread by each grid cell using a truck equipped with GPS and variable rate fertilizer spreaders. 

 
 
 
 
The benefits of variable-rate fertilizer application: 

1. Nutrient balance. All areas of the field receive the necessary amount of fertilizer. 
2. Potential increase in yields. More efficient fertilizer doses make increases more likely. 
3. Save on the amount of fertilizer used. Avoid overspending in areas where nutrient removal is low. 

 
 
 

Methods of VRT  
 

• Variable Rate Technology (VRT) refers to the instrumentation used for regulating application rates of 
fertilizer, lime, pesticides, and seed as an applicator travels across a field, based on a decision support 
system and(or) management plan. VRT resembles a back-to-basics approach to farming, with varying 
inputs across a field depending on a number of field and production variables. 

 
• The information needed to support VRT may come from several sources such as GPSreferenced data, 

RS images, and GISgenerated maps. All of the data are used to produce a site-specific application plan 
based on sound agronomic principles.  

 
• Current VRT equipment allows the user to monitor machine functions as mechanical applicators 

quickly react to changes in field conditions and make adjustments to field operation (seeding rates, 
fertilizer and chemical application rates, etc.).  

 
• When coupled with a GPS receiver, VRT provides the controlling mechanism to make adjustments 

based on the location of invisible lines predetermined by the farm manager or equipment operator.  
 

• VRT provides the opportunity to manage production based on soil type, soil texture, organic matter, 
nutrient levels, soil pH, weed and insect populations, disease, spatial pattern of nematode populations, 
desired yield, and other factors. 

 
 
 
Exercise: 

1) STCR stands for…………………………………………………….. 
2) VRT stands for……………………………………………………… 
3) KML stands for…………………………………………………….... 
4) GPS is based on a principle called 

a)Transmission 
b)Trilaterration 
c)Globalization 
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5) To determine the location of any position,receiver must receive signals from at least …………….GPS 
Satellite Vehicles. 
a)Three 
b)Four 
c)Two 
 

6) The NAVSTAR satellite system belongs to  
a) China  
b) Russia 
c) United States of America 
d) India 
 
 

Conclusion: 
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Practical 16: Particle size calculation from TEM/SEMimage 

Objective: Determination of average particle size of nanoparticles from transmission electron microscope 
(TEM)/scanning electron microscope (SEM) image 

 Sol- Gel technique: Sol-gel technique is one of the bottom-up technique to synthesize nanoparticles. Figure 
below shows the schematic diagram of the sol-gel technique. The synthesis of cobalt chromite nanoparticle 
(CoCr2O4) has been demonstrated as an example with some simpleSteps. 

 

 1. First, we have taken 0.2 g of raw Cobalt (Co) and 0.3 g of Chromium (Cr) metal powder in a clean beaker 
and dissolved it into 37% hydrochloric acid. The solution is then put over a magnetic rotor for 12 hrs to form a 
homogenous solution. 

*The work instruction belongs to a part of Nano-technology of the said course 

2. After that to form ionic bonding 3 g of citric acid is added in the solution and the solution is again 
homogenized for 12hrs. 
3.After the completion of the 2nd step the solution is put inside a vacuum oven at 500 C for 2 days to form a 
thickgel 
4.The gel is dried in the vacuum oven at 600 C over night to form a solidcake 
5.The cake was then ground in a mortar pestle and formed into a finepowder 
6.After that the powder is put into an alumina boat and kept inside the chamber furnace at 6000c for 6 hrs. 
toform CoCr2O4 nanoparticle. 
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Method to estimate particle size: 
 
Based on the particle size data obtained from TEM or SEM figure, particle size distribution was plotted. A 
typical way to present the particle size and its distribution is in the form of a number-frequency histogram. A 
histogram is a bar graph that illustrates the frequency of occurrence of particle versus the size range. Figure 1 
shows number of particles with particle size data in linear scale. 
 

 
 

Fig. 1.Number of particles histograms showing particle size distribution of nanoparticles in linear scale. 
 

AsitisobservedinFig.1,thesizedistributionoftheparticlesisskewedtowardthelargerendoftheparticle- size 
scale as the majority of real samples when plotted on the linear scale. The particle size range 
corresponding to the highest bar is estimated average particle size range of thesample. 

 
 Real Example: TEM image of CoCr2O4nanoparticle 

 
TEM images are used to characterize the nanoparticles. From TEM images it is possible to know about the 
particle size, shape, morphology, defect, structure of nanoparticles. For the calculation of average particle 
size, we generally use Photoshop software. Figure attached below are the TEM images of as synthesized 
CoCr2O4 nanoparticle. 

 

Fig. 2. TEM image of CoCr2O4 nanocrystalline sample 
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Average particle size calculation of CoCr2O4 nanocrystalline sample from TEM 
image: 

Table-1 
Determination of particle size distribution with number of particles 

Sl. No. Range of Particle Size (nm) Average particle size (nm) Number of particles 
1 10-15 12.5 2 

 15-20 17.5 13 
 20-25 22.5 28 
 .   
 .   
 .   
 .   
 .   
 .   
 .   
 .   
 50-55 52.5 2 

 
How to measure the crystallite size from Graphical representation: 

 
1. First take a mm. × mm. graph paper and choose to plot particle size along X-axis with number of 

particles withY-axis. 
2. Determine the appropriate coordinates of origin according to the datadistribution. 
3. Determine one smallest division value along both axis as per the data obtained in the table so that 

data distribution should cover at least 80% area of the total graphsheet. 
4. Particle size region with maximum particles denote the average crystallinesize. 

 
Example for method of drawing graph by referring to Table-1: 
 

1. From table 1 we see that the diameter of particles ranges between 10 to 55 nm, which should be 
the range of x-axis in our graph. Since the x-axis has first average value 12.5 nm in the graph, we 
have chosen the origin of the x-axis as 7.5 nm. The x-axis has 190 divisions so we need to 
divide(55-7.5)= 47.5 nm in 190 divisions which results into 1 smallest division (S. D.) as 0.25 
nm along x-axis. 

 
2. For the y-axis, the maximum number of particles is 28 and minimum is 2. Hence, 32 particles are 

divided into 240 mm, which makes 1 S. D. along y-axis as 0.13333. Since the particles are not 
measured in fraction so there is no unit associated with it to describe the no ofparticles. 

 
3. From table 1 we see that for 12.5 nm average particle size no of particle is 2. Mark the coordinate 

(12.5,2) in your graph paper. 
4. Again,wehave2particlesintherangeof10-15nm,toimplythisinformationselecttheareabetween (10,2) 

and (15,2) and create a shadedregion. 
5. Similar to this method draw other regionsalso. 
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 From this bar diagram we see that most of the particle resides in 20-30 nm region with maximum number 
of particles. Average of the region is 25 nm. Thus, from the bar diagram we can confirm that average 
particle size of the as synthesized CoCr2O4 nanoparticle is 25 nm. 

Video Link : 

https://drive.google.com/drive/folders/1DQmpcskb92Sz9CYn9B1fE9JpByUvpzs1?usp=sharing 

 

 

https://drive.google.com/drive/folders/1DQmpcskb92Sz9CYn9B1fE9JpByUvpzs1?usp=sharing
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Practical 17: Application of Drone Technology in agriculture 
Objective:  

By using drones for agriculture mapping, farmers can stay updated on the health of plants in a 
particular area and indicate which field areas require attention. To estimate the state of crops, 
drones inspect the field with infrared cameras and determine light absorption rates 

• What is drone and example? 
A drone is an unmanned aerial vehicle (UAV) or unmanned aircraft system. It is essentially a flying robot 
this is controlled remotely or can fly autonomously with software-controlled flight plans embedded in its 
system that work in conjunction with sensors and a global positioning system (GPS). 

 

• What is a drone in simple words? 
        Essentially, a drone is a flying robot that can be remotely controlled or fly autonomously using 
software-controlled flight plans in its embedded systems, that work in conjunction with onboard sensors 
and a global positioning system (GPS). 

• What is the Full form of drone? 
The name Drone refers to Dynamic Remotely Operated Navigation Equipment, it is also known as  
unmanned aerial vehicle (UAV), commonly known as a drone, is an aircraft without any human pilot, crew, 
or passengers on board. It is essentially a flying robot and is controlled remotely or can fly autonomously 
with software-controlled flight plans embedded in its system that work in conjunction with sensors and a 
global positioning system (GPS). Drones are of different types and sizes and are used for a variety of 
purposes 
 

 
 
 



Geoinformatics,nano-technology and precision farming 
 

67 | P a g e  
 

Benefits of agri-drones 

• Security 
The drones are operated by trained drone pilots. So, there are no chances of their misuse. 

• High efficiency 
Drones do not have any operational delays and can work double the speed of human labor. 

• Water-saving 
In comparison to traditional spraying methods, agricultural drones use ultra-low volume (ULV) 
spraying technology, thus saving more water. 

• Low cost and easy to maintain 
Agri drones are sturdy, low in cost, and require minimum maintenance. Some of the key features 
include a detachable container, low-cost frame, precise spraying of pesticides. 

Limitations of agri drones 

• Connectivity issue 
Often, online coverage is unavailable in rural areas. Under such circumstances, a farmer needs to 
invest in internet connectivity, which can turn into a recurring expense. 

• Weather dependent 
Drones do not have any operational delays and can work double the speed of human labor. 

• Weather dependent 
Drones are heavily dependent on good weather conditions. Under rainy or windy weather conditions, it 
is not advisable to fly drones. 

• Knowledge and Skill 
Using new technology is a welcoming change but using it daily requires the right skillset and adequate 
knowledge. An average farmer may struggle to understand drone functions. Either he must acquire the 
knowledge or remain dependent on an experienced person. 

Drones (at work) can be used in the following different stages of the crop cycle:   
1. Planning stage and emergence: Drones can be used for soil surveying and help reveal soil properties 
to plan for crop treatment and optimized farming. Analysis of changes in soil pH, texture and salinity etc. 
can help farmers in making better seeding decisions etc.  

2. Nutrient inputs, zonation, and precision spraying: An example of the use of drones is specialized and 
precise spray treatment by applying exactly where it is needed and with minimal manual involvement.  
3. Yield estimations: Drones can employ variety of cameras to capture different types of specialized 
images to generate vegetation indices which can be analysed to predict yields. 
 4. Crop monitoring and harvest; drones can be helpful in generating data that can help in optimized 
scheduling of crop harvest operations.  
5. Crop protection and insurance: All above uses of drones can also help various stakeholders related to 
crop protection and insurance gather relevant and more accurate data faster, thus helping in faster 
processing of insurance claims etc.  
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1)    The drone used for the assessing the health of plants need to be : 
 
a)   Near infrared equipped 
b) Equipped with 3D camera 
c)    Equipped with spraying facility 
d) GPS equipped 

 
2) What is the other name for a drone ? 
3) Use of drone in agriculture. 
 

 

 

 

 

 

 

 

 

 

 

Conclusion: 

 

 

Video Link : 

https://www.youtube.com/watch?v=9Yfh8I3E47o&pp=ygUfZHJvbmUgdGVjaG5vbG9neSBpbiB
hZ3JpY3VsdHVyZQ%3D%3D 
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