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Practical 1: Study of computer components and accessories 

 Objective: to analyze a problem, and identify and define the computing requirements 

appropriate to its solution 

 Requirements: Desktop, Keyboard, Mouse, CPU, Printer 

 Computer: A computer is a machine or device that performs processes, calculations and 

operations based on instructions provided by a software or hardware program. It has the ability 

to accept data (input), process it, and then produce outputs. 

 Features of a computer: 

1. High speed 

2. Reliability and Accuracy 

3. Storage and Retrieval of Large volumes of data/Information 

4. Ability to Communicate with other Computers 

    A Block diagram of a computer displays a structural representation of a computer system.  
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 Memory:  

Measurement of Memory: 

The memory required to store a word formed with 8 Bits of data/Information is called 

a BYTE.  

 Normally One byte of memory is required to store one Character  

1 Kilo Byte (KB) = 210 Bytes = 1024 Bytes 

1 Mega Byte (MB) = 210 KB = 1024 KB 

1 Giga Byte (GB) = 210 MB   = 1024 MB 

 Memory Devices: 

1) Semiconductor Memory: This type of memory is in the form of semiconductor IC’s. The 

advantages of this type of memory include compact size, high speed operation, low cost etc. 

But as these are fixed on the computer motherboard itself, there are limitations to the amount 

of memory which can be put on the motherboard. Semiconductor memory are of two types: 

 RAM (Random Access Memory): This is a read and writes type of Memory which is used by 

the computer as a scratch pad. 

 ROM (Read Only Memory): This is only read type of memory. This memory  is used for 

purposes like storing basic programs required by the computer at  the time of startup (called 

BIQS) 

2)  Storage Media: 

 Mainly Magnetic or semiconductor type of media, (except CD which is an  optical 

type of media) is used as Memory for storage of Data/Information.  Variety of storage media 

types is used depending on the amount of information to be stored. 

 Input Devices: 

Some commonly used input devices are listed below: 

1.  Key Board   2. Mouse 3.  Optical Scanner    4. Magnetic Card Reader. 

 Output Devices: 

1.  VDU (Video Display Unit   2. Printer    3. Plotter     4. Speaker 
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Exercise: 

1) Write Functions of units and some example devices of each : 

 

 
Unit Functions 

1. 

 

 

 

 

 

 

 

Central Processing 

Unit 

 

a)    ALU 

 

b)    Control Unit  

 

2. 

 
Memory  

3. 

 
Input device  

4. 

 
Output device  

 

2) Fill the capacity column in the following table : 

Sl. no. Type Capacity 

1. Floppy Diskettes  

2. Hard Disk  

3. Magnetic Tape (Cassette)  

4. Compact Disc (CD)  

5. Pen Drive  

 

3) Fill type of device and description column in the following table: 

 

Sl. 

No. 
Device 

Type of 

Device 
Description (function) 

1. RAM   

2. Hard Disc   

3. Floppy Disk   

4. Mouse   

5. Compact Disc   

6. Key Board   
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7. Visual Display Unit   

8 Printer   

9 Plotter   

10 Scanner   

 

4) Write configuration of Computers / Terminals available in the laboratory: 

  

 

 

 

  

 

 

 

  

 

 

 

 

 

 

Conclusion: 

 

 

 

 

 

Video Link: https://www.youtube.com/watch?v=5OHx1SxS8C0 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=5OHx1SxS8C0
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Practical 2: Practice of Important DOS Commands 

 Objective: To learn about important DOS commands. 

 Requirements: MS-DOS. 

 What is a disk operating system? 

A DOS, or disk operating system, is an operating system that runs from a disk drive.  

Most commonly used DOS is MS-DOS or Microsoft DOS. 

 Getting into MS DOS: 

 Start button and choose Run or click Windows+R. 

 In the Run dialog box, type CMD or COMMAND which is the extension file for MS-

DOS. 

 Click on the OK button and command prompt will open. 

           

Figure 1: Command Prompt  

 Command: A command is a set of instructions used to perform a specific work. Command 

interpreted by the OS interpreter to a machine language. 

 Types of DOS Commands:  

a) Internal Command: Internal commands are more commonly used and important. 

These commands are already loaded in the COMMAND.COM file because they can be 

quickly accessed and always available in MS-DOS and to Windows when needed.  

b) External command: These external commands are for performing advanced tasks and 

they do need some external file support as they are not stored in COMMAND.COM. 
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 Internal commands:  

 CLS: To clear the screen. 

Syntax: CLS, Example: C:\> CLS 

 CD: To change directory or move to a specific folder. 

      Syntax: CD[d:][path][dir name], Example: C:\> CD DESKTOP 

 CD..: Go to previous directory. 

Syntax: CD..[d:][path][dir name], Example: C:\> DESKTOP>CD.. 

 COPY CON: To create a file through the command line. 

Syntax: COPY CON [d:][path][name.ext], Example: C:\> desktop\ COPY CON 

Ram.txt 

 DIR: It displays a list of files and folders. 

Syntax: DIR [d:][path],  Example: C:\> desktop> DIR. 

 MD or MKDIR: To create new folders or directory. 

Syntax: MD or MKDIR [d:][path][dir name], Example: C:\> desktop> MD INDIA 

 RD: To delete folder or directory(s). 

Syntax: RD [d:][path][dirname], Example: C:\> desktop> RD INDIA 

 REN: To rename a file or files 

Syntax: REN [d:][path][name.ext] [d:][path][new name.ext] 

Example: C:\> desktop> REN INDIA BHARAT 

 MOVE: To move files from one folder to another. 

Syntax: MOVE [d:][ source path][name.ext] [d:][ destination path][name.ext] 

Example: C:\> desktop> MOVE Ram.txt BHARAT 

 TYPE: It displays the contents of a text file. 

Syntax: TYPE [d:][path][name.ext], Example: C:\> desktop> TYPE Ram.txt 

 VER: It displays version information. 

Syntax: VER, Example: C:\> VER. 

 VOL: To display a disk label. 

Syntax: VOL [drive:], Example: C:\> VOL 

 DEL: To delete files. 

Syntax: DEL [d:][path][name. ext], Example: C:\> desktop>DEL Ram.txt 

 COLOR: It changes color of the prompt 

Syntax: color [value], Example: C:\> color 1 

 DATE: To display or set the date. 
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Syntax: DATE, Example: C:\> DATE 

 TIME: To display or set the date. 

Syntax: time, Example: C:\> TIME 

 External commands: 

 EDIT: This command is used to modify or change the data of a file. 

Syntax: EDIT [filename], Example: C:\> desktop> EDIT Ram.txt 

 DISKCOPY: This command makes an exact copy of a disk, including hidden system 

files if they are present. 

Syntax: DISKCOPY [d1:] [d2:], Example: DISKCOPY C: E:, 

 CHKDSK: This command is used to check a disk and display a status report with 

properties of disk like serial number, volume label, memory and other properties. 

Syntax: CHKDSK [d:], Example: CHKDSK C: 

 FORMAT: This command is used to erase off information of a computer disk or fixed 

drive. 

Syntax: FORMAT [d:], Example: FORMAT E: 

 LABEL: This command is used to see the volume label and to change the volume label. 

Syntax: LABEL [d:], Example: LABEL C: 

 SCANDISK: This utility is used to repair and check various disk errors. 

Syntax: SCANDISK [d:], Example: SCANDISK C: 

 PRINT: This command prints a text file. 

Syntax: PRINT [d:][path][name.ext], Example: C:\> desktop> PRINT Ram.txt 

 TREE: This command displays list of directories and sub directories. 

Syntax: TREE [d:], Example: TREE C: 

 DELTREE: This command is used to delete files a directories same as DEL and RD. 

Syntax: DELTREE [d:][path][name.ext],  

Example: C:\>desktop> DELTREE Ram.txt 

 FIND: This command searches for a specific text string in a file or files. 

Syntax: FIND “STRING”[name.ext],  

Example: C:\>desktop> FIND “MY” Ram.txt 

 SORT: This command is used to arrange the data of a file in alphabetical order or 

reverse alphabetical order. 

Syntax: SORT [name.ext]  

Example: C:\>desktop> SORT Ram.txt 

 BACKUP: The Backup command backs up one or more files from one disk to another.  
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Syntax: BACKUP [d1:][d2:] 

Example: BACKUP C: D:  

 XCOPY: This command is used to copy files and directory trees from one disk to 

another disk. 

Syntax: XCOPY   source   [destination] 

Example: C:\>desktop> XCOPY INDIA NATION 

Exercise: 

1. Which command lists the current directory of disk? 

a) COPY. 

b) CD. 

c) TREE. 

d) DIR. 

2. If you don’t know the time, which command you will use to display? 

a) DATE. 

b) TIME. 

c) CD. 

d) NONE. 

3. While working with MS-DOS which command transfers one specific file from one disk 

to another? 

a) COPY. 

b) DISKCOPY. 

c) Time. 

d) Rename. 

4. If you need to copy entire disk, which command you will use? 

a) COPY. 

b) DISKCOPY. 

c) CHKDSK. 

d) FORMAT. 

5. Which command used to clear the screen? 

a) Clear. 

b) CLS. 

c) Clear screen. 

d) All of the above. 

6. The command used to copy a file name temp.doc from drive C: to drive A: 
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a) Copy temp.doc to a: 

b) Copy c:\> temp.doc a: 

c) Copy a:\> temp.doc c: 

d) Copy temp a: c:  

7. External command DOS are: 

a) Copy, edit, format. 

b) Edit, chkdsk, xcopy. 

c) Chkdsk, xcopy, del. 

d) Del, format, edit. 

8. __________ command moves to previous directory? 

9. DOS is an ____________ software? 

10. To remove directory the _____________ command is used. 

11. Write difference between internal commands and external commands? 

12. Write the use of COPY, XCOPY, DISKCOPY commands? 

 

Conclusion: 

 

 

 

 

 

 

Video Link: 

https://www.youtube.com/watch?v=F7kXXsEq2Vc&t=122s&ab_channel=SelfAdhyanG

uruji 

 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=F7kXXsEq2Vc&t=122s&ab_channel=SelfAdhyanGuruji
https://www.youtube.com/watch?v=F7kXXsEq2Vc&t=122s&ab_channel=SelfAdhyanGuruji
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Practical 3: Introduction to different operating systems such as MS-

Windows, Unix/ Linux, Creating Files and Folders, File Management 

 Objective: To learn about different operating systems like Windows and Unix/Linux and how 

to create and manage files in those operating systems. 

 Requirements: Windows and Unix/Linux operating system in PC or laptop. 

 Windows OS 

 Microsoft introduced an operating environment named Windows on November 20, 

1985, as a graphical operating system shell for MS-DOS.  

 It is the most popular and simplest operating system; it can be used by any person who 

can read and understand Basic English. 

 Elements of Windows OS: 

 Graphical User Interface,  

 Icons (pictures, documents, application, program icons, etc.),  

 Taskbar,  

 Start button,  

 Windows explorer, 

 Mouse button,  

 Hardware compatibility,  

 Software compatibility,  

 Help etc. 

 Versions of Windows Operating System: 

Windows 1.0(1985), Windows 2.0(1987), Windows 3.0(1990), Windows 95(1995), 

Windows 98(1998), WindowsME(2000), Windows NT(1993), Windows 2000(2000), 

Windows XP(2001), Windows Vista(2006), Windows 7(2009), Windows 8/8.1(2012), 

Windows 10(2015) and Windows 10 S(2017). 

 Creating File and Folders, File management: 

File Explorer is the file management application used by Windows operating systems 

to browse folders and files. 

There are a couple of ways to open File Explorer.  

1. The shortcut Win+E will open File Explorer.  

2. It can also be opened by clicking the Start button and typing “File Explorer”  
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3. Right-click any folder and then select Open.  

 

 To open a folder: 

From File Explorer, double-click a folder to open it or select the folder, right click and 

select open from the menu. You can then see all of the files stored in that folder. Notice 

that you can also see the location of a folder in the address bar near the top of the 

window. 

 To open a file: 

Find the file on your computer and double-click it or select the file, then right click, 

then select open from the menu. This will open the file in its default application. 

Or 

Open the application, and then use the application to open the file. Once the application 

is open, you can go to the File menu at the top of the window and select Open. 

 To move a file or folder: 

1. Click and drag the file to the desired location. If you drag the file or folder one drive to 

another drive it will copy and if you drag it with in two same drive irwil move 

2. Release the mouse. The file will appear in the new location. 

You can use this same technique to move an entire folder. Note that moving a folder will 

also move all of the files within that folder. 

 To create a new folder: 

Within File Explorer, locate and select the New folder button. 

Or 
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In Windows 7, there is a New folder button near the top of the window. In Windows 

10, you can also click the Home tab, then the New Folder button. 

Or 

You can also right-click where you want the folder to appear, then select New > 

Folder 

Or  

You can use CTRL+SHIFT+N 

The new folder will appear. Type the desired name for the folder and press Enter.The new 

folder will be created. You can now move files into this folder. 

 

 To create a new file: 

To create a file in a folder, first right-click, then select New after that select which file 

you want to create like word file, text file, excel file etc. 

 To rename a file or folder: 

1. Click the file or folder, wait about one second, and click again. An editable text field 

will appear. 

Or 

You can also right-click the folder or file and select Rename from the menu. An 

editable text field will appear. 

2. Type the desired name on your keyboard and press Enter. The name will be changed. 
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 To delete a file or folder: 

When you delete a file, it is moved to the Recycle Bin. If you change your mind, you can 

move the file from the Recycle Bin back to its original location and to delete a file permanently, 

first right-click the Recycle Bin icon and then select Empty Recycle Bin. All files in the 

Recycle Bin will be permanently deleted. 

Click and drag the file to the Recycle Bin icon on the desktop. 

Or 

You can also click the file to select it and press the Delete key on your keyboard. 

Or 

You can also right-click the folder or file and select Delete from the menu. 

 Selecting multiple files or folders: 

If you're viewing your files as icons, you can click and drag the mouse to draw a box around 

the files you want to select. 

Or 

To select specific files from a folder, press and hold the Control key on your keyboard, then 

click the files you want to select. 

Or 

To select a group of files from a folder, click the first file, press and hold the Shift key on 

your keyboard, then click the last file. All of the files between the first and last ones will be 

selected. 

 If you want to select all files or folders in a folder at the same time, open the folder in 

File Explorer and press CTRL+A. All of the files in the folder will be selected. 

 Unix/Linux OS 

 The Unix Operating System is the earliest operating system developed in 1970s. 

 Multitasking. 

 Multiuser computer operating systems. 

 Comparative complex functionality. 

 It does not give notice or warn about the consequences of a user’s action. 

 Unix Architecture: 

 Kernel: The kernel is the heart of the operating system. It interacts with the hardware 

and most of the tasks like memory management, task scheduling and file management. 
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 Shell: The shell is the utility that processes your requests. When you type in a command 

at your terminal, the shell interprets the command and calls the program that you want. 

 Commands and Utilities: There are various commands and utilities to do specific 

activities. Example: cp, mv, cat etc.  

 Files and Directories: All the data of Unix is organized into files. All files are then 

organized into directories. These directories are further organized into a tree-like 

structure called the File system. 

Linux is one of popular version of UNIX operating System. It is open source as its 

source code is freely available. It is free to use. Linux was designed considering Unix 

compatibility. Its functionality list is quite similar to that of Unix. 

 File management 

 Creating and Editing Files: 

You can use the vi editor to create ordinary files on any Unix system.  

Syntax:$ vi filename 

The above command will open a file with the given filename. Now, press the key i to 

come into the edit mode. Once you are in the edit mode, you can start writing your content in 

the file. 

Once you are done with the program, follow these steps − 

1.  Press the key esc to come out of the edit mode. 

2. Press Shift + Z to come out of the file completely. 

 Display Content of a File: 

cat: cat command is used to see the content of a file. 

Syntax: $ cat filename 

 Counting Words in a File: 

wc: This command is used to get a count of the total number of lines, words, and 

characters contained in a file. 

Syntax: $ wc filename 

x y z filename 

Here is the detail of all the four columns − 

 First Column (x) − Represents the total number of lines in the file. 
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 Second Column (y) − Represents the total number of words in the file. 

 Third Column (z) − Represents the total number of bytes in the file. This is the actual 

size of the file. 

 Fourth Column − Represents the file name. 

 Copying Files: 

cp: To make a copy of a file. 

Syntax: $ cpsource_filedestination_file 

 Renaming Files: 

mv: To change the name of a file. 

Syntax: $ mv old_filename new_filename 

 Deleting Files: 

rm: To delete an existing file. 

Syntax: $ rm filename. 

 Listing Files: 

ls: To list the files and directories stored in the current directory. 

Syntax: $ls 

The command ls support the -l option which would help you to get more information about the 

listed files. 

Syntax: $ls–l 

$ls –a: This command is used to show the hidden files. 

We use meta characters* to match 0 or more characters, a question mark (?) matches with a 

single character. 

For example:  

$ls *.doc: To display all the files ending with just .doc. 

 Directory management: 

Home Directory: The directory in which you find yourself when you first login is called your 

home directory. 

$cd ~: To go in home directory anytime. 

$cd -: To go Last directory. 

$cd ~username: To go in any other user's home directory. 
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pwd (point working directory) command: To determine where you are within the file 

system hierarchy at any time. 

 Listing Directories:  

ls: To list the directories. 

Syntax: $lsdirname 

 Creating Directories:  

mkdir: To create directories. 

Syntax: $mk dir dirname 

 Removing Directories:  

rmdir: To delete or remove directories. 

Syntax:$rm dir dirname 

 Changing Directories: 

cd: You can use it to change to any directory by specifying a valid absolute or relative 

path. 

Syntax:$cd dirname 

$cd..: This command is use for taking to the previous directory. 

 A pathname is absolute, if it is described in relation to root and absolute pathnames 

always begin with a /. 

Example: / users /chem/notes 

 A pathname can also be relative to your current working directory. Relative pathnames 

never begin with /. 

Example: chem/notes 

 Renaming Directories: 

mv: This command used to rename a directory. 

Syntax:$mv olddir newdir. 

Exercise: 

1. Which of the following is not an operating system? 

a) Windows 

b) Linux 

c) Oracle 

d) DOS 
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2. When were MS windows operating systems proposed? 

a) 1994 

b) 1990 

c) 1992 

d) 1985 

3. Which is the Linux operating system? 

a) Private operating system 

b) Windows operating system 

c) Open-source operating system 

d) None of these 

4. In Unix, which command is use to remove directory? 

a) rd 

b) rmdir 

c) rdir 

d) All of the above 

5. cd command only accepts _____ as arguments: 

a) path 

b) repository 

c) Directories 

d) File 

6. Compare Windows, Unix and Linux operating system.  ( five points) 

Conclusion: 

 

 

 

 

 

Video Link: 

1. https://www.youtube.com/watch?v=mej9mQHWMKE&ab_channel=AmitThinks 

2. https://www.youtube.com/watch?v=IVquJh3DXUA&ab_channel=sakitech 

3. https://www.youtube.com/watch?v=1ROOqJ9yNT0&t=220s&ab_channel=Androidand

TechSolutions 

https://www.youtube.com/watch?v=mej9mQHWMKE&ab_channel=AmitThinks
https://www.youtube.com/watch?v=IVquJh3DXUA&ab_channel=sakitech
https://www.youtube.com/watch?v=1ROOqJ9yNT0&t=220s&ab_channel=AndroidandTechSolutions
https://www.youtube.com/watch?v=1ROOqJ9yNT0&t=220s&ab_channel=AndroidandTechSolutions
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Practical 4: Use of Microsoft Word 

 Objective: To learn how to create, edit and format any document using Microsoft Word. 

 Requirement: Microsoft Word in Laptops or PC. 

 Microsoft Word: Microsoft word or MS Word is a graphical word processor program that 

users can type with. 

 Where we can find Microsoft Word? 

Follow these simple steps to open MS Word on your personal computer: 

                Start → All Programs → MS Office → MS Word. 

 Creating a new document 

To create a document in MS-Word, follow these steps: 

 Step 1: From the menu bar, Click the File tab and select the New option. 

 Step 2: Select and Double click on the Blank document, or 

 Press CTRL+N. 

 

                                               Figure 1: Creating a document 

 Opening existing document 

To open an existing document in MS-Word, follow these steps: 

 Step 1: From the menu bar, Click the File tab and select the Open option. 

 Step 2: Select the file which you want to open, or 

 Press CTRL+O. 
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 Saving a document 

To save a document, follow any step among these three steps: 

 Click on the save button on the Tool bar, or 

 From the menu bar, Click the File tab and select the Open option, or 

 Press CTRL+S. 

 Printing a document 

To print a document, follow these steps: 

 Step 1: From the menu bar, Click the File tab and select the Print option,or 

 Press CTRL+P. 

 Step 2: Select the Printer and Set different properties. 

 Formatting Text 

 Font and Font size: 

 Step 1: Click Home tab 

 Step 2: Next type the name of desired font or font size directly or select from the drop 

down list. 

 Font Style: 

 Select the text and click on the bold or italic or underlined button. 

 Alternatively, click on the bold or italic or underlined button and type the text. 

 Select the text and use respective shortcut keys like CTRL+B (Bold), CTRL+I 

(Italics), CTRL+U (Underlined). 

 

Figure 2: Changing Font and Font Size 

 Formatting Paragraph: 

 Spacing between lines: 
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 Step 1: Select the paragraph or paragraphs for which you want to define spacing. 

 Step 2: Paragraph Dialog Box launcher available on the Home tab, to the right of the 

paragraph spacing controls, you find the “Line spacing” tools. 

 Step 3: Click the Line and Paragraph Spacing Button triangle to display a list of options 

to adjust space between the lines 

You have different custom settings like: Single, 1.5 lines, double, At least, Exactly, Multiple. 

 Spacing between lines: 

 Step 1: Select the paragraph or paragraphs for which you want to define spacing and 

click the Paragraph Dialog Box launcher available on the Home tab. 

 Step 2: You will find the “Before and After” option in Paragraph Dialog Box. Click the 

Before and After spinner to increase or decrease the space before or after the selected 

paragraph. 

 Alignment of Text 

Click one of the alignment buttons in the Paragraph group on the Home Tab: 

 Left (CTRL+L): Aligns the lines in the paragraph flush on the left side and ragged on 

the right. 

 Centered (CTRL+E): Centres each line in the paragraph, leaving both left and right 

margins ragged. 

 Right (CTRL+R): Aligns the lines in the paragraph flush on the right side and ragged 

on the left. 

 Justified (CTRL+J): Add space between letters and words so that both the left and 

right sides of the paragraph are straight and flush with the margins. 

 Formatting Page 

You can set a page from Page Setup section under the Page Layout. In this section 

you can set Page margin, Page orientation, Paper size. 

 CUT, COPY and PASTE 

These edit functions are used to move and copy a selected text from one place to another: 

To Cut and Copy: 

 Go to Home Tab>Cut (CTRL + X) or Copy (CTRL+C) 

 Then PASTE (CTRL+V) in desired position. 
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 FIND, REPLACE and GOTO 

 Step 1: Click on Home tab Replace. A Find And Replace dialog box will be displayed 

on the screen. 

 Step 2: From there you can find any text; you can replace any text by finding text and 

go to any page, line or section. 

 Headers and Footers 

 Step 1: Click on Insert Tab. You will find Header and Footer options. 

 Step 2: You can type your information whatever you want to have in your document 

header and once you are done, click Close Header and Footer to come out of the header 

or footer insertion mode. 

 Table 

 Click the Insert tab followed by the Table button. This will display a simple grid as 

shown below. When you move your mouse over the grid cells, it makes a table in the 

table that appears in the document.  

 You can make your table having the desired number of rows and columns. 

 

Figure 3: Creating a Table 

Shortcut Keys: 

 Ctrl + A -- Select all contents of the page.    

 Ctrl + B -- Bold highlighted selection. 

 Ctrl + C -- Copy selected text. 

 Ctrl + X -- Cut selected text. 

 Ctrl + N -- Open new/blank document. 
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 Ctrl + O -- Open options. 

 Ctrl + P -- Open the print window. 

 Ctrl + F -- Open find box. 

 Ctrl + I -- Italicise highlighted selection. 

 Ctrl + K -- Insert link. 

 Ctrl + U -- Underline highlighted selection. 

 Ctrl + V -- Paste. 

 Ctrl + Y -- Redo the last action performed. 

 Ctrl + Z -- Undo last action. 

Exercise: 

 

1. Which is the default alignment in word? 
(A) Left 

(B) Right 

(C) Centre 

(D) Justify 

2. File extension of word document is: 
(A) .xls 

(B) .doc 

(C) .word 

(D) .jpeg 

3. Portrait and Landscape are ________ . 
(A) Paper size 

(B) Page layout 

(C) Page orientation 

(D) Page margin 

4. Fill in the blanks: 

a. ____________ shows the name of the application and name of the file ?        

b. ______________   can be used to select the entire document? 
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c. When entering text within a document, the enter key is normally pressed at the 

end of every ______________? 

d. The _________________   features helps you to avoid typing mistake and speed 

up your typing? 

e. Ctrl+V is shortcut for ____________ operation? 

5. How can we set up a page in Microsoft word? 

6. Make you curriculum vitae in Microsoft word in one or two pages.  

Conclusion: 

 

 

 

 

 

 

 

 

Video Link: 

https://www.youtube.com/watch?v=yV4i29Xo0iM&t=7734s&ab_channel=LearnitTraining 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=yV4i29Xo0iM&t=7734s&ab_channel=LearnitTraining
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Practical 5: MS Excel Mathematical calculations, Preparation of Spread Sheets 

 Objective: To learn how to create, edit and format any document using Microsoft Excel. 

 Requirement: Microsoft Excel in Laptops or PC. 

 Microsoft Excel: Microsoft Excel is an example of a program called a “spreadsheet.” 

Microsoft Office Excel is a powerful tool used to create and format spreadsheets. Spreadsheets 

allow information to be organized in rows and tables and analyzed with automatic mathematics. 

Spreadsheets are commonly be used to perform many different types of calculations. 

 Where we can find Microsoft Excel? 

Follow these simple steps to open MS Word on your personal computer: 

                Start → All Programs → MS Office → MS Excel. 

 Creating a new document 

To create a document in MS- Excel, follow these steps: 

 Step 1: From the menu bar, Click the File tab and select the New option. 

 Step 2: Select and Double click on the Blank document, or 

 Press CTRL+N. 

 Opening existing document 

To open an existing document in MS-Word, follow these steps: 

 Step 1: From the menu bar, Click the File tab and select the Open option. 

 Step 2: Select the file which you want to open, or 

 Press CTRL+O. 

 Saving a document 

To save a document, follow any step among these three steps: 

 Click on the save button on the Tool bar, or 

 From the menu bar, Click the File tab and select the Open option, or 

 Press CTRL+S. 
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 MS Excel Formulas: 

The main function of MS Excel is to perform computations and calculations using the data 

stored in the worksheets. This is done by replacing actual numbers with references to the cells 

where they are stored in the table – the cells’ names – in manually written mathematical 

formulas or Excel specific formulas.  

SUM: The sum function is another mathematical function used to sum up the selected numbers, 

whether they are decimals or whole numbers. We can either select the cells containing numbers 

one by one or directly select the complete range of cells whose sum we need to find. 

Syntax: = SUM (number1, number2,…..)  

                            or   

=SUM (1st cell address:last cell address) 

 

 

 

 

 

 

 

 

 

 

 

AVERAGE: An easier way to do this calculation, especially for a large number of data cells, 

is to use an Excel formula. The formula for computing the mean is called “AVERAGE”. It uses 

as parameter the area where the data is located, indicated by the upper left cell and the lower 

right cell, separated by “:”. Attention: any computation performed in MS Excel must begin 

with the symbol “=”. 

Syntax: = AVERAGE (number1, number2,…..)  
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                            OR 

= AVERAGE (1st cell address: last cell address) 

 

 

 
 

Product: Product excel function is an inbuilt mathematical function which is used to calculate 

the product or multiplication of the given number provided to this function as arguments, so 

for example, if we provide this formula arguments as 2 and 3 as =PRODUCT(2,3) then the 

result displayed is 6, this function multiplies all the arguments. 

Syntax: = PRODUCT(number1,number2,…..) 

 

 

MAX and MIN: The MAX and MIN formulas in Excel get the largest and smallest value in a 

set of numbers, respectively. For our sample data set, the formulas will be as simple as: 

Syntax: = MAX (number1,number2,…..) 

              = MIN (number1,number2,…..) 

              = MAX(B2:B13) 

             = MIN(B2:B13) 
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 MAX function - find the highest value. 

 MIN function - return the smallest value in a data set. 

 

 

 

 

COUNT: If you are curious to know how many cells in a given range contain numeric 

values (numbers or dates), don't waste your time counting them by hand. The Excel COUNT 

function will bring you the count in a heartbeat:  

Syntax: COUNT(1st cell address : last cell address) 

https://www.ablebits.com/office-addins-blog/2019/10/16/max-function-excel-highest-value/
https://www.ablebits.com/office-addins-blog/2019/11/14/min-function-excel/
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Median: The MEDIAN Function is categorized under Excel Statistical functions. The function 

will calculate the middle value of a given set of numbers. Median can be defined as the middle 

number of a group of numbers. That is, half the numbers return values that are greater than the 

median, and half the numbers return values that are less than the median. 

Syntax: MEDIAN (1st cell address : last cell address) 

 

Mode: Mode function in excel is another type of function which allows only numbers. Mode 

function returns the most frequently occurring number from the selected range or value. For 

example, if there are 3 cells in the range out of 3, 2 cells contain the same number, then the 

Mode function will return that number repeated 2 times. And if all the 3 cells contain different 

numbers, then we will get an error message as #N/A, as the Mode function couldn’t return 

anything. 

Syntax: MODE (1st cell address : last cell address) 

https://corporatefinanceinstitute.com/resources/excel/functions/
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Standard Deviation: Standard Deviation is a measure which shows how much variation (such 

as spread, dispersion, spread,) from the mean exists. The standard deviation indicates a 

“typical” deviation from the mean. Standard deviation calculates the extent to which the values 

differ from the average. Standard Deviation, the most widely used measure of dispersion, is 

based on all values. 

Syntax: STDEV (1st cell address : last cell address) 
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AND & OR 

These are the two most popular logical functions to check multiple criteria. The difference is 

how they do this: 

 AND returns TRUE if all conditions are met, FALSE otherwise. 

Syntax: = AND(Condition1,Condition2…….) 

 OR returns TRUE if any condition is met, FALSE otherwise. 

Syntax: = OR(Condition1,Condition2…….) 

TODAY & NOW 

To see the current date and time whenever you open your worksheet without having to 

manually update it on a daily basis, use either: 

=TODAY() to insert the today's date in a cell. 

=NOW() to insert the current date and time in a cell. 

How to Create Spreadsheet in Excel? 

Microsoft Excel is a spreadsheet program that is part of Microsoft Office. 

Step 1: Open MS Excel. 

Step 2: Go to Menu and select New >> click on the Blank workbook to create a simple 

worksheet. 

OR – Just press Ctrl + N: To create a new spreadsheet. 

Step 3: By default, Sheet1 will be created as a worksheet in the spreadsheet, and the name of 

the spreadsheet will be given as Book1 if you are opening it for the first time 
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To Rename a worksheet: 

1. Double click on the tab 

2. The name Sheet1 is selected 

3. Enter the new name 

OR Worksheet >>Home>>Cell command>>Format>>Rename sheet>>new name 

type>>Enter key press 

 

To Insert a worksheet: 

 In Excel 2007 click the insert sheet button which is located next to the worksheets(at bottom 

sheet1,sheet2 etc)  

OR Home ribbon >> cell command >>Insert >>Insert sheet OR Shift+F11 
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To Delete a Worksheet: 

To delete a sheet in Excel 2007,use the right click menu>and delete button 

OR Worksheet >>Home>>Cells>>Delete>>Delete sheet>>dialog box>>Delete 

 

 

Exercise: 

1) MS Excel stands for ___________ 

A. Micromax Excel 

B. Management Excel 

C. Microsoft Excel 

D. Microsoft Excess 

2) MS Excel is a ________. 

A. Database Management software 

B. Presentation software 

C. Workbook software 

D. Spreadsheet software 

3) Microsoft Excel 2007 has column limit of __________ 

A. 13684 

B. 16384 
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C. 18634 

D. 84163 

4) MS Excel 2007 has row limit of __________ 

A. 1,048,576 

B. 4,81,0576 

C. 16384 

D. 1,57,648 

5) Formulas in Excel start with ________ 

A. / 

B. f 

C. – 

D. = 

6) File that contains one or more worksheets to organize data is known as _______ 

A. Workbook 

B. Excelbook 

C. Datasheet 

D. Spreadsheet 

7) The intersection of a column and a row in MS Excel worksheet is known as _______ 

A. Row 

B. Cell 

C. Column 

D. Tab 

8) In Microsoft Excel spreadsheets, rows are labelled as _______ 

A. 1,2,3 

B. A,B,C 

C. A1,B1,C1 

D. I,II,III 

9) In Microsoft Excel spreadsheets, COLUMNS are labelled as _______ 

A. 1,2,3 
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B. A,B,C 

C. A1,B1,C1 

D. I,II,III 

10) In Microsoft Excel spreadsheets, CELLS are labelled as _______ 

A. 1,2,3 

B. A,B,C 

C. A1,B1,C1 

D. I,II,III,….. 

11) How are data organized in a spreadsheet?  

a.   Lines and spaces 

b.   Layers and planes 

c.   Rows and columns 

d.   Height and width 

 

Conclusion: 

 

 

 

 

Video Link:    https://www.youtube.com/watch?v=Jl0Qk63z2ZY 

https://www.youtube.com/watch?v=e7xGuGqgp-Q 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=Jl0Qk63z2ZY
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Practical 6 : MS Excel chart –Line,XY,Bar and PIE 

Objective: To learn how to create different type of chart using Microsoft Excel.  

Requirement: Microsoft Excel in Laptops or PC 

Microsoft Excel: Microsoft Excel is an example of a program called a “spreadsheet.” Microsoft Office 

Excel is a powerful tool used to create and format spreadsheets. Spreadsheets allow information to be 

organized in rows and tables and analyzed with automatic mathematics. Spreadsheets are commonly be 

used to perform many different types of calculations. 

Where we can find Microsoft Excel? 

Follow these simple steps to open MS Word on your personal computer: 

                Start → All Programs → MS Office → MS Excel 

What is a chart?  

A chart is a visual representative of data in both columns and rows. Charts are usually used to analyse 

trends and patterns in data sets.  

What is a bar Chart? 

A bar chart is a graph that shows horizontal bars with the axis values for the bars displayed on the 

bottom of the graph. 

How to Create a Bar Chart? 

To create a line chart in Excel 2007, you will need to do the following steps: 

Steps to Create a Bar Chart 
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 Highlight the data that you would like to use for the bar chart. In this example, we have selected 

the range B2:C13. 

 
 

 Select the Insert tab in the toolbar at the top of the screen. Click on the Bar button in the Charts 

group and then select a chart from the drop down menu. In this example, we have selected the 

first bar chart (called Clustered Bar) in the 2-D Column section. 

 

 

 Now you will see the bar chart appear in your spreadsheet with horizontal bars to represent both 

Maximum temperature and Minimum temperature for each month. Maximum temperature (°C) 

is displayed as blue horizontal bars and  Minimum temperature(°C) is displayed as red 

horizontal bars. You can see the axis values on the bottom of the graph for these horizontal 

bars. 
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 Finally, let's add a title for the bar chart. By default, your chart will be 

created without a title in Excel 2007. 

 

 

 

 

 

 To add a title, select the Layout tab under Chart Tools in the toolbar at the top of the 

screen (Chart Tools will only appear when you have the chart selected). Click on the 

Chart Title button in the Labels group and then select "Above Chart" from the drop 

down menu. 

 Now you should see a title appear at the top of the chart area. Click on the title and it 

will become editable. Enter the text that you would like to see as the title.  

 What is a Line Chart? 

A line chart is a graph that shows a series of data points connected by straight lines.              

How to Create a Line Chart? 

Steps to Create a Line Chart 

To create a line chart in Excel 2007, you will need to do the following steps: 

 Highlight the data that you would like to use for the line chart. In this example, we have 
selected the range B2:B11. 
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 Select the Insert tab in the toolbar at the top of the screen. Click on the Line button in 

the Charts group and then select a chart from the drop down menu. In this example, we 

have selected the fourth line chart (called Line with Markers) in the 2-D Line section 

 

 

 Now you will see the line chart appear in your spreadsheet showing the trend for one weather 

data (ie: Rainfall). The blue series of data points represents the trend for Rainfall. 

 

 Finally, let's add a title for the line chart. By default, your chart will be created without a title 

in Excel 2007. 

 To add a title, select the Layout tab under Chart Tools in the toolbar at the top of the screen 

(Chart Tools will only appear when you have the chart selected). Click on the Chart Title button 

in the Labels group and then select "Above Chart" from the drop down menu. 

 Now you should see a title appear at the top of the chart area. Click on the title and it will 

become editable.  
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How to Create a Line and a Bar Chart? 

 

 
 

 

What is a Pie Chart? 

A pie chart is a circle that is divided into slices and each slice represents a proportion of the whole. 

Steps to Create a Pie Chart: 

To create a pie chart in Excel 2007, you will need to do the following steps: 

 Highlight the data that you would like to use for the pie chart. In this example, we have 
selected the range A2:B5. 

 

 Select the Insert tab in the toolbar at the top of the screen. Click on the Pie button in 

the Charts group and then select a chart from the drop down menu. In this example, we 

have selected the first pie chart (called Pie) in the 2-D Pie section. 
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 Now you will see the completed pie chart. the pie chart has 4 slices (one for each 

division). Each slice represents the sales as a percentage of the Maximum temp. 

What is a XY graph? 

We can use Excel to plot XY graph, also known as scatter chart or XY chart. With such charts, we can 

directly view trends and correlations between the two variables in our diagram.  

 

A scatter plot or scatter chart is a chart used to show the relationship between two quantitative variables. 

A scatter chart has a horizontal and vertical axis, and both axes are value axes designed to plot numeric 
data.  

 

 Highlight the data that you would like to use for the pie chart. In this example, we have 

selected the range B2:C11. 

 

 Select the Insert tab in the toolbar at the top of the screen. Click on the Scatter button 

in the Charts group and then select a chart from the drop down menu. In this example, 
we have selected the first scatter chart. 

 

 Now you will see the completed scatter chart.  

 To add a title, select the Layout tab under Chart Tools in the toolbar at the top of the 

screen (Chart Tools will only appear when you have the chart selected). Click on the 

Chart Title button in the Labels group and then select "Above Chart" from the drop 
down menu. 

 Now you should see a title appear at the top of the chart area. Click on 
the title and it will become editable.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Agri-Inforatics 

41 
 

Exercise: 

1) Which of the following Excel charts represents only one value for each variable? 

(A) Bar 

(B) Pie 

(C) Line 

(D) Function 

2) What is the extension of saved file in MS Excel? 

(A) .xls 

(B) .xks 

(C) .xos 

(D) .xbs 

Conclusion:  

 

 

 

 

 

Video Link: https://youtu.be/Z2gzLYaQatQ 

 

 

 

 

 

 

 

 

 

 

https://youtu.be/Z2gzLYaQatQ
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Practical 7: MS-Access: Creating Database, Preparation of queries, reports 

and forms 

 Objective: To learn about how to create database, prepare queries, reports and forms in MS-

Access. 

 Requirements: MS-Access. 

 MS-Access: 

Microsoft Access is a Database Management System (DBMS) from Microsoft that combines 

the relational Microsoft Jet Database Engine with a graphical user interface and software 

development tools. 

 Where we can find Microsoft Access? 

Follow these simple steps to open MS Access on your personal computer: 

                Start → All Programs → MS Office → MS Access. 

 Microsoft Access stores information which is called a database. To use MS Access, you will 

need to follow these four steps- 

 Database Creation: Create your Microsoft Access database and specify what kind of 

data you will be storing. 

 Data Input: After your database is created, the data of every business day can be 

entered into the Access database. 

 Query: This is a fancy term to basically describe the process of retrieving information 

from the database. 

 Report: Information from the database is organized in a nice presentation that can be 

printed in an Access Report. 

 Before MS Access 2007, the file extension was *.mdb, but in MS Access 2007 the extension 

has been changed to *.accdb extension. 

 MS Access Objects: 

Databases in Access are composed of many objects but the following are the major 

objects – 

1. Table: Table is an object that is used to define and store data. When you create 

a new table, Access asks you to define fields which is also known as column 

headings. 

 Each field must have a unique name and data type. 
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 Tables contain fields or columns that store different kinds of data such as a 

name or an address and records or rows that collect all the information about 

a particular instance of the subject such as all the information about a customer 

or employee etc. 

 You can define a primary key, one or more fields that have a unique value for 

each record. 

2. Queries: An object that provides a custom view of data from one or more tables. 

Queries are a way of searching for and compiling data from one or more tables. 

 Running a query is like asking a detailed question of your database. 

 When you build a query in Access, you are defining specific search conditions 

to find exactly the data you want. 

 In Access, you can use the graphical query by example facility or you can write 

Structured Query Language (SQL) statements to create your queries. 

 You can define queries to Select, Update, Insert, or Delete data. 

3. Form: Forms are used to customize the presentation of data that your 

application extracts from queries or tables. 

Forms are used for entering, modifying, and viewing records. 

4. Report: Report is an object in desktop databases designed for formatting, 

calculating, printing, and summarizing selected data. 

 You can view a report on your screen before you print it 

 Reports are useful because they allow you to present components of 

your database in an easy-to-read format. 

 If forms are for input purposes, then reports are for output. 

 Access offers you the ability to create a report from any table or query. 

 Creating a database:  

Open Microsoft Access. Click on the Blank Database icon. Access asks you to enter the new 

database name near the bottom-right corner of the window. Type in the database name and 

press the Create button. 

                             Example: Employee_database. 
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Figure 1: Creating Database in MS Access 

 Creating Table in Database: 

 First we you have to add all the fields you need into the table. This is done by clicking 

on the button in the Views group of the Datasheet tab. 

 You are then prompted to enter a name for your table. 

 In the design view, you will see the field ID, and that it is set as an AutoNumber. Here 

you can add fields with their data types. Example: Employee Name, Salary etc. 

 Primary Keys: A primary key is a field or set of fields used to uniquely identify records 

in a table. A primary key value is always unique in the table.  

                               Example: Empolyee_ID. 

 

         Figure 2: Creating Table: Fields, data types, Primary key 
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         Figure 3 : The table in datasheet view 

 A new table can be created by pressing the Table button in the Tables group under the 

Create tab on the ribbon. 

 Creating Queries: 

 Under the Create tab, click on the Query Design button from the Queries group. 

 Select which tables you would like to include in the query. You can always bring up 

the Show Table dialog box either by right-clicking, or by selecting the Show Table 

button from the Query Setup group. 

 Access now shows you the design view of your query. This form of queries is called 

query by example or QBE. To add all the fields of the table into the query, double-click 

the *. 

 Now, to see the result of your query, click on the Run button under the Results group. 

 

Figure 4 : Creating Query 

  To display the employee details whose salary is 20, go through the following figure: 
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Figure 5 : Query Design 

To display the employee details whose salary is 20, or less than 40 go through the following 

figure: 

 

Figure 6 : Query Design 
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 Creating Reports:  

 Go to the Create tab and click on Report Wizard in the Reports Group. 

 The report wizard pops up and allows you to select one or more tables and/or 

queries you want to include in your report. You can select the fields by using 

the arrow buttons in the wizard. 

 The next screen allows you to group records based on a particular field. 

 You can also sort records within a group, press Next 

 You can also select different layouts for your report,  press Next 

 Finally, type in your report title and press Finish. 

     

Figure 7: Creating Report 

 

Figure 8: Report Output 
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 Creating Form:  

 Forms provide a nice interface for entering data into tables and for viewing 

existing data. To create a form for table, first make sure that the table is open. 

Navigate to the Create tab, then in the Forms group, click on the Form button. 

 You can drag fields and labels around the form as you wish. You can also 

change the colors and formatting of the form. 

     

    Figure 9: Form View in MS Access 

Exercise: 

13. Which of the following is not a database object? 

e) Form 

f) Table 

g) Relationship 

h) Object 

14. What does the show check box in query design window indicate? 

e) It indicates whether the field is to be used or not. 

f) It indicates whether the field is to be displayed in query result or not. 

g) It indicates whether the field names to be displayed in query result or not. 

h) It indicates whether the field is to be used for grouping result or not. 

15. What is a form that we can create in MS Access ? 

a) It is used to take printout of a form from Access Tables. 



Agri-Inforatics 

49 
 

b) It is an input screen for viewing and entering data. 

c) It is used for storing special data other than text (e.g photo). 

d) It is optional. We can use Report instead of Form. 

16. The columns in a Microsoft access table are also called _______ 

e) Rows 

f) Records 

g) Fields 

h) Tuple 

17. How can we create a query in Microsoft Access? 

e) Drag and drop fields 

f) Type the SQL 

g) Use query wizard 

h) All of the above. 

18. The key uniquely identify each record in a table? 

e) Key record 

f) Primary Key 

g) Composite Key 

h) Foreign Key  

19. Which of the following database object hold data? 

e) Forms 

f) Tables 

g) Reports 

h) Queries. 

20. Which of following is a/are view/views to display a table in database? 

a) Datasheet View 

b) Design View 

c) Both 

d) None 

21. Microsoft Access is a ______ kind of application? 

a) RDBMS 

b) OODBMS 

c) ORDBMS 

d) None 
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22. Which of the following shows the final result in a presentable way? 

a) Forms 

b) Reports 

c) Queries 

d) Tables 

 

Conclusion: 

 

 

 

 

 

Video Link: 

https://www.youtube.com/watch?v=1XTXv1V3-ag&ab_channel=LearnitTraining 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=1XTXv1V3-ag&ab_channel=LearnitTraining
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Practical 8: Microsoft PowerPoint 

 Objective: To learn how to create any presentation using Microsoft PowerPoint. 

 Requirement: Microsoft PowerPoint in Laptops or PC. 

 Microsoft PowerPoint: PowerPoint is a graphical presentation program used to organize and 

present information. PowerPoint presentations consist of a number of individual pages or 

"slides”. Slides may contain text, graphics, sound, movies, and other objects that can be freely 

arranged. 

 Where we can find Microsoft PowerPoint? 

Follow these simple steps to open MS PowerPoint on your personal computer: 

                Start → All Programs → MS Office → MS PowerPoint. 

 

Various areas in a PowerPoint 

 Ribbon and Menus in PowerPoint 

PowerPoint offers a host of tools that will aid you in creating a presentation. These tools 

are organized logically into various ribbons in PowerPoint. The table below describes the 

various commands you can access from the different menus. 

Menu Category Ribbon Commands 

Home Clipboard functions, manipulating slides, 

fonts, paragraph settings, drawing objects 

and editing functions 

Insert Insert tables, pictures, images, shapes, 

charts, special texts, multimedia and 

symbols 

Design Slide setup, slide orientation, presentation 

themes and background 
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Transitions Commands related to slide transitions 

Animations Commands related to animation within 

the individual slides 

Slideshow Commands related to slideshow set up 

and previews 

Review Proofing content, language selection, 

comments and comparing presentations 

View Commands related to presentation views, 

Master slides, color settings and window 

arrangements 

 

 

Different Menus and Categories in PowerPoint 

 Creating a new Presentations 

To create a document in MS-PowerPoint, follow these steps: 

 Step 1: Click the File tab and select the New option. 

 Step 2: Select and Double click on the Blank presentation, or 

 Press CTRL+N. 

 Opening existing presentations 

To open an existing presentation in MS-PowerPoint, follow these steps: 

 Step 1: Click the File tab and select the Open option. 

 Step 2: Select the file which you want to open, or 

 Press CTRL+O. 

 Click on Recent, It displays a list of your most recently created presentations 

and their file locations. Clock on the file which you want to open. 
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 Saving a presentation 

To save a presentation, follow any step among these steps: 

 Click on the save button on the Tool bar, or 

 Click the File tab and select the Save option, or 

 Press CTRL+S. 

 Printing a presentation 

To print a presentation, follow these steps: 

 Step 1: Click the File tab and select the Print option, or 

 Press CTRL+P. 

 Step 2: Select the Printer and Set different properties. 

 PowerPoint Slides 

 When you choose to create a blank presentation, PowerPoint will open a presentation 

with a Title Slide. Once the Title Slide is open, you’ll see a slide with two placeholder 

text boxes for a title and a subtitle. 

 Adding New Slide:  

 To add a New Slide, make sure you’re on the Home tab. The New Slide button 

will add slides to your presentation or 

 Right-click in the Navigation Pane under any existing slide and click on the 

New Slide option. Or  

 Press Ctrl+M 

 To change the slide layout, right-click on the newly inserted slide and go to the 

Layout option where you can choose from the existing layout styles available 

to you. 

 

Adding New Slide in a presentation 

 Applying Theme: PowerPoint has many pre‐set designs and themes that include 

complimentary colors and fonts : 
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 To add a theme to a presentation, go to the Design tab in the ribbon. There are 

several themes immediately available. To use one of the built‐in themes, just 

click on its thumbnail. 

 If you don’t want to use a theme, you can add Background Styles. From this 

selection, you can add some preset background styles that change according to 

the colors you’ve chosen. 

 

Themes in PwerPoint 

 Adding Content: 

 Text is the default content of the slide below. The format for the default text is a bulleted 

list. To add text, click and begin typing.  

 To add other content, click on the icon within the content group on the new slide. 

 Tables: 

 Set the number of columns and rows as needed in the Insert Table dialog box and click 

OK.  

 Methods for editing and the design and layout of your table are located on the Table 

Tools contextual tab. 

 

Table in PowerPoint 

 Charts: 

 Click Insert > Chart.  
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 Click the chart type and then double-click the chart you want like Column, Bar, Pie, 

XY etc. 

 In the worksheet that appears, replace the placeholder data with your own information. 

 When you’ve finished, close the worksheet. 

 

Charts in PowerPoint 

 SmartArt Graphics: 

 SmartArt graphics are shapes that are designed to represent the relationship between 

things or people. You might use SmartArt for an organizational chart or a timeline. 

 Click Insert > SmartArt 

 SmartArt styles and layouts can be formatted in the SmartArt Tools contextual tab. 

 

SmartArt in PowerPoint 

 Shapes: 

Given below are the steps to add a shape in PowerPoint. 

 Go to the Illustrations group under the Insert Tab. 

 Click on the Shapes dropdown to view the available shapes. 

 Select the shape you want to insert. This will change the cursor to a + sign. 

 The shape formatting features in PowerPoint can be accessed from the Format 

ribbon. 

Adding Text in Shape:  

 Right-click on the shape to which you want to add the text and select the Edit 

Text option. 

 Start typing the text into the shape. Once you are done, click the cursor anywhere 

outside the shape. 
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 Pictures: 

 Click Insert > Picture 

 From the insert tab you can also add any screenshot, photo album, audio, video and 

symbols. 

 Transitions: 

Add slide transitions to bring your PowerPoint presentation to life. 

 Select the slide you want to add a transition to. 

 Select the Transitions tab and choose a transition. 

 Select a transition to see a preview. 

 Select Effect Options to choose the direction and nature of the transition. 

 To remove a transition, select Transitions > None. 

 

Transitions in Power Point 

 Animations: 

Add animations to text, pictures, shapes, and more in your presentation. 

 Select the object or text you want to animate. 

 Select Animations and choose an animation. 

 Select Effect Options and choose an effect. 
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Animation option in Power Point 

 Slide show: 

To start a slide show: 

 Click the Start From Beginning command on the Quick Access Toolbar, or press 

the F5 key at the top of your keyboard. The presentation will appear in full-

screen mode. 

 Select the Slide Show view command at the bottom of the PowerPoint window 

to begin a presentation from the current slide. 

 Go to the Slide Show tab on the Ribbon to access even more options. From here, 

you can start the presentation from the current slide (Shift+F5) and access 

advanced presentation options. 

 

Slide Show in Power Point 

To stop a slide show: 

 You can exit presentation mode by pressing the Esc key on your keyboard. 

Alternatively, you can click the Slide Show Options button in the bottom-left 

and select End Show. 

 Copy or Cut and Paste any slide: 

 Select the slide and right click then choose copy or cut the slide or use Ctrl+C or Ctrl+X. 
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 Then Paste the slide or Ctrl+V in between two slides where you want to paste. 

 Adding Slide number and Date: 

 Click on the insert from menu 

 Select Header & Footer or Slide number or Date & Time under the Text group. 

 Select the Check Boxes for Date and Time and Slide number from the Header & Footer 

Dialog box. 

 

Exercise: 

7. In PowerPoint, the header and footer button can be found on the insert tab in what 

group?  

(A) Tables group 

(B) Text group 

(C) Object group 

(D) Illustrations group 

8. What is the default PowerPoint standard layout? 

(A) Blank 

(B) Title slide 

(C) Title only 

(D) Comparison 

9. Which type of view is not present in MS PowerPoint? 

(A) Extreme animation 

(B) Slide show 

(C) Slide sorter 

(D) Normal 

10. Which PowerPoint view displays each slide of the presentation as a thumbnail and is 

useful for rearranging slides? 

(A) Slide Master 

(B) Slide Show 

(C) Slide Sorter 

(D) Notes Page 

11. To open power point from the Run Dialog Box, type: 

(A) PowerPoint 

(B) Powerpnt 
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(C) Pwrpoint 

(D) Powerpint 

12. The page to create presentation in PowrPoint is called: 

(A) Sheet 

(B) Paper 

(C) Slide 

(D) Document 

13. Shortcut key for slide show view is:  

(A) F1 

(B) F2 

(C) F5 

(D) F7 

14. Fill in the blanks: 

f. File extension for PowerPoint presentation ____________?        

g. Microsoft PowerPoint is a ______________ program? 

h. The title of a presentation is displayed in the ____? 

i. The basic unit of any PowerPoint presentation is a(n) _____________? 

j. _______________is a default style of layout? 

k. Elements such as lines, arrows, callouts and banners that can be added to a slide 

are known as __________________. 

l. To delete more than one slide simultaneously, select the first slide, hold down 

the ___ key, and then select each additional slide that you want to delete. 

 

Conclusion: 

 

 

 

 

Video Link: 

https://www.youtube.com/watch?v=rvh_c_K3UU0&list=RDCMUCqyBfm_H9ugGirk1ufYA2Y

A&index=2&ab_channel=LearnitTraining 

https://www.youtube.com/watch?v=rvh_c_K3UU0&list=RDCMUCqyBfm_H9ugGirk1ufYA2YA&index=2&ab_channel=LearnitTraining
https://www.youtube.com/watch?v=rvh_c_K3UU0&list=RDCMUCqyBfm_H9ugGirk1ufYA2YA&index=2&ab_channel=LearnitTraining
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Practical 9: Basic concept of HTML for creating a Web page 

 Objective: To learn how to create any web pages using HTML. 

 Requirement: Note Pad in Laptops or PC. 

 Web Page: A web page is a document which is commonly written in HTML and translated by 

a web browser. A web page can be identified by entering an URL. A Web page can be of the 

static or dynamic type. With the help of HTML only, we can create static web pages. 

 HTML: HTML is an acronym which stands for Hyper Text Markup Language which is used 

for creating web pages and web applications. 

 Hyper Text: HyperText simply means "Text within Text." A text has a link within it, 

is a hypertext. Whenever you click on a link which brings you to a new webpage, you 

have clicked on a hypertext. 

 Markup language: A markup language is a computer language that is used to apply 

layout and formatting conventions to a text document. Markup language makes text 

more interactive and dynamic. It can turn text into images, tables, links, etc. 

 How to create a new web page :  

Following are some easy ways to create your first web page with Notepad: 

Step 1: Open Notepad 

Step 2: Write code in HTML 

Step 3: Save the HTML file with .htm or .html extension. 

Step 4: Open the HTML page in your web browser. 

 Building blocks of HTML: 

Tags: An HTML tag surrounds the content and apply meaning to it. It is written between < 

and > brackets. 

Attribute: An attribute in HTML provides extra information about the element, and it is 

applied within the start tag. An HTML attribute contains two fields: name & value. 

          <tag name  attribute_name= " attr_value"> content </ tag name>   

 HTML Documents: 

 All HTML documents must start with a document type declaration: <!DOCTYPE 

html>. 

 The HTML document itself begins with <html> and ends with </html>. 

 The visible part of the HTML document is between <body> and </body>. 
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 HTML Headings: 

HTML headings are defined with the <h1> to <h6> tags 

Ex:-    <h1>Heading 1</h1> 

<h2>Heading 2</h2> 

           <h3>Heading 3</h3> 

 HTML Paragraphs:  

The HTML <p> element defines a paragraph. 

Ex:- <p>This is a paragraph.</p> 

 HTML Styles:  

The HTML style attribute is used to add styles to an element, such as color, font, size, and 

more. 

<tagname style="property:value;"> 

 Use the style attribute for styling HTML elements. 

 Use background-color for background color. 

Ex:- <body style="background-color:powderblue;"> 

 Use color for text colors. 

Ex:- <p style="color:red;">This is a paragraph.</p> 

 Use font-family for text fonts 

Ex:- <p style="font-family:courier;">This is a paragraph.</p> 

 Use font-size for text sizes 

Ex:- <p style="font-size:160%;">This is a paragraph.</p> 

 Use text-align for text alignment 

Ex:- <p style="text-align:center;">Centered paragraph.</p> 

 HTML Text Formatting: 

Formatting elements were designed to display special types of text: 

 <b> - Bold text 

 <strong> - Important text 

 <i> - Italic text 

 <em> - Emphasized text 

 <mark> - Marked text 

 <small> - Smaller text 

 <del> - Deleted text 

 <ins> - Inserted text 
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 <sub> - Subscript text 

 <sup> - Superscript text 

 HTML Quotation and Citation Elements:  

 <blockquote> element defines a section that is quoted from another source. Browsers 

usually indent blockquote elements. 

Ex:- <blockquote >For nearly 60 years</blockquote> 

 <q> tag defines a short quotation 

Ex:- <p>WWF's goal is to: <q>Build a future where people live in harmony with 

nature.</q></p> 

 <abbr> tag defines an abbreviation or an acronym 

Ex:- <p>The <abbr title="World Health Organization">WHO</abbr> was founded in 

1948.</p> 

 <cite> tag defines the title of a creative work. The text in the <cite> element usually 

renders in italic. 

Ex:- <p><cite>The Scream</cite> by Edvard Munch. Painted in 1893.</p> 

 <address> tag defines the contact information for the author/owner of a document or an 

article. 

The contact information can be an email address, URL, physical address, phone 

number, social media handle, etc. 

The text in the <address> element usually renders in italic, and browsers will always 

add a line break before and after the <address> element. 

 HTML Comments: 

HTML comments are not displayed in the browser, but they can help document your HTML 

source code. 

<!-- Write your comments here --> 

 HTML Colors:  

HTML colors are specified with predefined color names like tomato, orage etc. 

Background Color, Text Color, Border Color. 

 HTML Links:  

The HTML <a> tag defines a hyperlink. The most important attribute of the <a> element is the 

href attribute, which indicates the link's destination. 

<a href="url">link text</a> 

Ex:- <a href=" https://www.google.com/">Visit Google</a> 
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 HTML Images:  

 <img> tag is used to embed an image in a web page.  

 The <img> tag has two required attributes: 

 src - Specifies the path to the image 

 alt - Specifies an alternate text for the image (If user can’t see the image) 

 <img src="url" alt="alternatetext"> 

 Image Size - Width and Height: You can use the style attribute to specify the width and 

height of an image. 

Ex:- <img src="image.jpg" alt="My Image" width="500" height="600"> 

 HTML Tables:  

 A table in HTML consists of table cells inside rows and columns. 

 <table> tag Defines a table 

 Each table cell is defined by a <td> and a </td> tag. 

 Each table row starts with a <tr> and end with a </tr> tag. 

 <th> tag Defines a header cell in a table. 

Ex:-     <table> 

         <tr> 

              <td>Section A </td> 

               <td>Section B</td> 

               <td>Section C</td> 

        </tr> 

</table> 

 HTML Lists: 

Unordered HTML List: 

An unordered list starts with the <ul> tag. Each list item starts with the <li> tag. 

Ex:-       

      <ul> 

            <li>Coffee</li> 

            <li>Tea</li> 

            <li>Milk</li> 

     </ul> 

Ordered HTML List: 

An ordered list starts with the <ol> tag. Each list item starts with the <li> tag. 

Ex:-  



Agri-Inforatics 

64 
 

      <ol> 

         <li>Coffee</li> 

         <li>Tea</li> 

         <li>Milk</li> 

     </ol> 

HTML Description Lists: 

 A description list is a list of terms, with a description of each term. 

 The <dl> tag defines the description list, the <dt> tag defines the term (name), and the 

<dd> tag describes each term. 

Ex:-  

<dl> 

   <dt>Coffee</dt> 

   <dd> black hot drink</dd> 

   <dt>Milk</dt> 

   <dd> white cold drink</dd> 

 </dl> 

 HTML - The Head Element:  

The <title> element is required and it defines the title of the document. 

<head> Defines information about the document 

 HTML Styles – CSS: 

Cascading Style Sheets (CSS) is used to format the layout of a webpage. 

CSS can be added to HTML documents in 3 ways: 

 Inline - by using the style attribute inside HTML elements 

 Internal - by using a <style> element in the <head> section 

 External - by using a <link> element to link to an external CSS file 

 Inline CSS: 

 An inline CSS is used to apply a unique style to a single HTML element. 

 An inline CSS uses the style attribute of an HTML element. 

Ex:- <h1 style="color:blue;">A Blue Heading</h1> 

 Internal CSS: 

 An internal CSS is used to define a style for a single HTML page. 

 An internal CSS is defined in the <head> section of an HTML page, within a <style> 

element. 
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Ex:- 

<head> 

<style> 

body {background-color: powderblue;} 

h1   {color: blue;} 

p    {color: red;} 

</style> 

</head> 

<body> 

<h1>This is a heading</h1> 

<p>This is a paragraph.</p> 

</body> 

 External CSS: 

 An external style sheet is used to define the style for many HTML pages. 

 To use an external style sheet, add a link to it in the <head> section of each HTML 

page: 

Ex:- 

<head> 

    <link rel="stylesheet" href="styles.css"> 

</head> 

<body> 

<h1>This is a heading</h1> 

<p>This is a paragraph.</p>  

</body> 

 The external style sheet can be written in any text editor. The file must not contain any 

HTML code, and must be saved with a .css extension. 

body { 

           background-color: powderblue; 

         } 

h1 { 

       color: blue; 

     } 

p { 

     color: red; 

    }. 
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Exercise:  

1. HTML stands for –  

a) HighText Machine Language 

b) HyperText and links Markup Language 

c) HyperText Markup Language 

d) None of these 

2. Which of the following tag is used for inserting the largest heading in HTML? 

a) <h3> 

b) <h1> 

c) <h5> 

d) <h6> 

3. Which of the following tag is used to insert a line-break in HTML? 

a) <br> 

b) <a> 

c) <pre> 

d) <b> 

4. How to create a hyperlink in HTML? 

a) <a href = "www.javatpoint.com"> javaTpoint.com </a> 

b) <a url = "www.javatpoint.com" javaTpoint.com /a> 

c) <a link = "www.javatpoint.com"> javaTpoint.com </a> 

d) <a> www.javatpoint.com <javaTpoint.com /a> 

5. How to create an ordered list (a list with the list items in numbers) in HTML? 

a) <ul> 

b) <ol> 

c) <li> 

d) <i> 

6. HTML tags are enclosed in- 

a) # and # 

b) { and } 

c) ! and ? 

d) < and > 

7. How to insert an image in HTML? 

a) <img href = "jtp.png" /> 
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b) <img url = "jtp.png" /> 

c) <img link = "jtp.png" /> 

d) <img src = "jtp.png" /> 

8. Which of the following tag is used to add rows in the table? 

a) <td> and </td> 

b) <th> and </th> 

c) <tr> and </tr> 

d) None of the above 

9. An HTML program is saved by using the ____ extension. 

a) .ht 

b) .html 

c) .hml 

d) None of the above 

10. Which of the following is the correct syntax for referring the external style sheet? 

a) <style src = example.css> 

b) <style src = "example.css" > 

c) <stylesheet> example.css </stylesheet> 

d) <link rel="stylesheet" type="text/css" href="example.css"> 

11. The HTML attribute used to define the internal stylesheet is – 

a) <style> 

b) style 

c) <link> 

d) <script> 

12. MarkUp tags tells the web browser: 

a) How to organise the page 

b) How to display the page 

c) How to display message box on page 

d) None of these 
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Conclusion:  

 

 

 

 

 

 

 

 

 

Video Link: 

https://www.youtube.com/watch?v=NAEHbzXMNpA&list=PLWPirh4EWFpFI-

w62QiV62FOVHcXnynon&ab_channel=TutorialsPoint%28India%29Ltd. 

Tutorial ink: 

https://www.w3schools.com/html/ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.youtube.com/watch?v=NAEHbzXMNpA&list=PLWPirh4EWFpFI-w62QiV62FOVHcXnynon&ab_channel=TutorialsPoint%28India%29Ltd.
https://www.youtube.com/watch?v=NAEHbzXMNpA&list=PLWPirh4EWFpFI-w62QiV62FOVHcXnynon&ab_channel=TutorialsPoint%28India%29Ltd.
https://www.w3schools.com/html/
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Practical 10: Demonstration of Agri-information Systems 

 Objective: To learn about different Agri-information Systems. 

 Agri-information system: An agricultural information system can be defined as a system, in 

which agricultural information is generated, transformed, transferred, consolidated and 

received. 

 Agricultural Resources Information system (AgRIS):  

 The Agricultural Resources Information System (AgRIS) is an e-governance 

programme for fostering agricultural growth, poverty reduction and sustainable 

resource use in India at grassroots level by the Department of Agriculture and 

Cooperation (DAC).  

 Users can get information about the National Spatial Data Infrastructure (NSDI) on 

agriculture, guidelines on standardized methodology, the best practices to be used and 

the Decision Support Systems (DSS) on Production Practices and Systems. 

Website: https://www.india.gov.in/agricultural-resources-information-system 

Here we get various website links for various information related different field of Agriculture 

like:  

 Indian Farmers Fertilizers Cooperative Ltd 

 List of agricultural machinery manufacturers 

 High yielding rice varieties developed at Central Rice Research Institute 

 Contact key officials in Agriculture and Cooperation Department 

 Livestock health details by Department of Animal Husbandry 

 National Project for Cattle and Buffalo Breeding 

 

https://www.india.gov.in/agricultural-resources-information-system
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KRISHI (ICAR research data repository for knowledge management): Agricultural 

Knowledge Resources and Information System Hub for Innovations, is an initiative of Indian 

Council of Agricultural Research (ICAR) to bring its knowledge resources to all stakeholders 

at one place. The portal is being developed as a centralized data repository system of ICAR 

consisting of Technology, Data generated through Experiments/ Surveys/ Observational 

studies, Geo-spatial data, Publications, Learning Resources etc. 

Krishi Website: https://krishi.icar.gov.in/ 

 

In this data repository there are various information systems for  

1. AICRPs & Network Projects: AICRPs & Network Projects is a scheme of Indian 

Council of Agricultural Research for development/testing/identification of 

technologies through multi-location trials. 

 

https://krishi.icar.gov.in/
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2. Bio-informatics resources. 

 

3. Crop Specific knowledge resources like: AGRIdaksh, Agro-advisory services for 

rice, Caneinfo, Disease and pest diagnostic system for tuber crops. 

 

4. Databases like: Agricultural Research Data Book (ICAR-IASRI), Agro-

meteorological Data at ICAR-CRIJA (ICAR-CRIJAF), Animal Genetic Resources of 

India (ICAR-NBAGR) etc. 

 

http://ctcri.org/tools/oushadham/oushadham.php
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5. Experimental data resources 

 

6. Genetic resource portal: 

 

7. Geo-Portal: 
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8. Mobile-App Gallery: 

 

9. Inter porter harvester: 

 

10. Institutional Publications and data inventory repository: 
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11. KVKs: 

 

12.  Management information systems: 

 

13. Museums: 
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14. Statistical learning and computing resources: 

 

15. Technologies and Knowledge resources: 

 

 

Exercise:  

1. Write a short note about KRISHI. 

Conclusion: 
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Practical 11: Introduction to Programming Language : C 

 Objective: To learn programming languages like C  

 Requirement: Microsoft visual studio code and Mingw-w64 via MSYS2 to install GCC on 

Windows OS. 

 C-Programming Language:  

C programming is a general-purpose, procedural, imperative computer programming language 

developed in 1972 by Dennis M. Ritchie. 

 C Programs 

A C program can vary from 3 lines to millions of lines and it should be written into one or more 

text files with extension ".c"; for example-hello.c. 

 C-Program Structure:  

A C program basically consists of the following parts − 

 Pre-processor Commands 

 Functions 

 Variables 

 Statements & Expressions 

 Comments 

Example:  

#include <stdio.h> 

int main() { 

   /* my first program in C */ 

   printf ("Hello, World! \n");    

   return 0; 

     } 

 The first line of the program #include <stdio.h> is a preprocessor command, which 

tells a C compiler to include stdio.h file before going to actual compilation. 

 The next line int main () is the main function where the program execution begins. 

 The next line /*...*/ will be ignored by the compiler and it has been put to add additional 

comments in the program. So such lines are called comments in the program. 

 The next line printf (...) is another function available in C which causes the message 

"Hello, World!" to be displayed on the screen. 
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 The next line return 0; terminates the main () function and returns the value 0. 

 Tokens in C:  

A C program consists of various tokens and a token is either a keyword, an identifier, a 

constant, a string literal, or a symbol. 

C Supports Six Types of Tokens: 

1. Identifiers: Identifiers are names given to different entities such as constants, variables, 

structures, functions, etc. Ex: int amount; amount is identifier. 

2. Keywords: You can't use a keyword as an identifier in your C programs, its reserved 

words in C library and used to perform an internal operation. The meaning and working 

of these keywords are already known to the compiler. Ex: int, double, return etc. 

3. Constant: Constants are like a variable, except that their value never changes during 

execution once defined. It is considered best practice to define constants using only 

upper-case names. 

Syntax: const type constant_name; 

Ex: const int SIDE = 10; 

4. Strings: In C programming, the one-dimensional array of characters are called strings. 

Ex: char name[6] = {'C', 'l', 'o', 'u', 'd', '\0'}; or char name[] = "Cloud"; 

5. Operators: C operators are symbols that are used to perform mathematical or logical 

manipulations. The C programming language is rich with built-in operators. Operators 

take part in a program for manipulating data and variables and form a part of the 

mathematical or logical expressions.  

Arithmetic Operators: Addition (+), Subtraction (-), Multiplication (*), Division (/), 

Modulus (%). 

Logical operators: &&(And), || (Or), ! (not)  

Relational Operators: Is equal to (= =) , Is not equal to(!=), Greater than(>), Less 

than(<), Greater than or equal to(>=), Less than or equal to(<=). 

 

 C - Data Types 

C provides various types of data-types which allow the programmer to select the appropriate 

type for the variable to set its value. Data types are void, int, char, double and float. 
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void As the name suggests, it holds no value and is generally used for 

specifying the type of function or what it returns. If the function has a void 

type, it means that the function will not return any value. 

int Used to denote an integer type. 

char Used to denote a character type. 

float, double Used to denote a floating point type. 

 

Example: int age; char  letter; float  height, width; 

 C- Type Casting 

Type Casting in C is used to convert a variable from one data type to another data type, and 

after type casting compiler treats the variable as of the new data type. 

Syntax: (type_name) expression. 

 C- variables:  

The primary purpose of variables is to store data in memory for later use. Unlike constants 

which do not change during the program execution, variables value may change during 

execution. 

Syntax: 

type variable_name; 

or 

            type variable_name, variable_name, variable_name; 

Example:  

    int    width, height=5; 

    char   letter='A'; 

    float  area; 

                double d; 

 C- Input/output 

Majority of the programs take data as input, and then after processing the processed data is 

being displayed which is called information. In C programming you can use scanf () and printf 

() predefined function to read and print data. 
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Example: 

 #include<stdio.h> 

int main() 

{ 

  int a,b,c; 

printf("Please enter any two numbers: \n"); 

scanf("%d %d", &a, &b); 

c =  a + b; 

printf("The addition of two number is: %d", c); 

} 

The easiest and simplest of all I/O operations are taking a character as input by reading that 

character from standard input (keyboard). getchar() function can be used to read a single 

character. 

Syntax: var_name = getchar(); 

 C-Format Specifier 

 

Format Specifier Description 

%d Integer Format Specifier 

%f Float Format Specifier 

%c Character Format Specifier 

%s String Format Specifier 

Syntax: printf ("%d",<variable name>); 

 C-Decision making : 

C conditional statements allow you to make a decision, based upon the result of a condition. 

These statements are called Decision Making Statements or Conditional Statements. 

 

if Statement:  

If statements in C is used to control the program flow based on some condition, it's used to 

execute some statement code block if the expression is evaluated to true. 

Syntax:  

if(test_expression) 
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{ 

    statement 1; 

    statement 2; 

    ... 

} 

If-else Statement:  

If else statements in C is also used to control the program flow based on some condition, only 

the difference is: it's used to execute some statement code block if the expression is evaluated 

to true, otherwise execute else statement code block. 

Syntax: 

if(test_expression) 

{   //execute your code 

}else 

{ 

  //execute your code 

} 

Nested if-else statements: 

It means you can use conditional statements inside another conditional statement. 

Syntax:  

if(test_expression one) 

{  

   if(test_expression two) { 

        //Statement block Executes when the boolean test expression two is true. 

          } 

} 

else 

{ 

       //else statement block 

} 
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 C-Loops:  

Sometimes it is necessary for the program to execute the statement several times. A loop 

executes a block of commands a specified number of times until a condition is met. 

while loop:  

while loop is a most basic loop in C programming. while loop has one control condition, and 

executes as long the condition is true.  The condition of the loop is tested before the body of 

the loop is executed, hence it is called an entry-controlled loop. 

Syntax:  

While (condition) 

{ 

   statement(s); 

    Incrementation; 

} 

do while: 

C do while loops are very similar to the while loops, but it always executes the code block at 

least once and furthermore as long as the condition remains true. This is an exit-controlled 

loop. 

Syntax:  

do 

{ 

     statement(s); 

} 

While ( condition ); 

for loop: 

C for loops is very similar to a while loops in that it continues to process a block of code until 

a statement becomes false, and everything is defined in a single line. The for loop is also entry-

controlled loop. 
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Syntax:  

for ( init; condition; increment ) 

{ 

   statement(s); 

} 

 C-Function:  

C-function is a self-contained block of statements that can be executed repeatedly whenever 

we need it. 

Types: 

 Built-in(Library) Functions 

The system provided these functions and stored in the library. Therefore it is also called Library 

Functions.e.g. scanf(), printf(), strcpy, strlwr, strcmp, strlen, strcat etc. 

To use these functions, you just need to include the appropriate C header files. 

 User Defined Functions These functions are defined by the user at the time of writing the 

program 

Syntax:  

returnType  functionName(Function arguments){ 

  //body of the function  

} 

Example:  

#include<stdio.h> 

int main() 

{    

    int answer; 

    answer = addition(); //calling a function to get addition value. 

    printf("The addition of the two numbers is: %d\n",answer); 

} 

//function returning the addition of two numbers 

int addition() 

https://www.w3schools.in/c-tutorial/library-functions/
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{ 

    int num1 = 10, num2 = 5; // local variable definition 

    return num1+num2; 

}. 

Some examples of C-Program: 

1. C- Program for sum of two number: 

#include<stdio.h> 

int main() 

{ 

     int a=500, b=30, c; 

     c=a+b; 

     printf ("Sum of two number is: %d", c); 

} 

2. C program to display the multiplication table of a given number:  

#include <stdio.h> 

int main() { 

    int num, i = 1; 

    printf("Enter any Number:"); 

    scanf("%d", &num); 

    printf("Multiplication table of %d:", num); 

 

    while (i <= 10) { 

        printf("%d x %d = %d", num, i, num * i); 

        i++; 

    } 

    return 0; 

} 

 

3. C-Program for Prime number check. 

#include <stdio.h>  
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int main() { 

  int n, i, c = 0; 

  printf("Enter any number n:"); 

  scanf("%d", &n); 

  for (i = 1; i <= n; i++) { 

      if (n % i == 0) { 

         c++; 

      } 

  } 

  if (c == 2) { 

  printf("n is a Prime number"); 

  } 

  else { 

  printf("n is not a Prime number"); 

  } 

  return 0;     

} 

4.  C-Program to find the greatest number of three numbers. 

#include <stdio.h> 

int main(){ 

    int a, b, c; 

    printf("Enter a,b,c: "); 

    scanf("%d %d %d", &a, &b, &c);    

    if (a > b && a > c) { 

        printf("a is Greater than b and c"); 

    } 

    else if (b > a && b > c) { 

        printf("b is Greater than a and c"); 

    } 

    else if (c > a && c > b) { 
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        printf("c is Greater than a and b"); 

    } 

    else { 

        printf("all are equal or any two values are equal"); 

    }  

    return 0; 

} 

Exercise:  

1. Write a C program C program adds n number of times which will be entered by the user. 

2. Write a C program to check whether the given number is even or odd. 

 

Conclusion: 

 

 

Video Link: 

1. C-Programming Tutorial:  

https://www.youtube.com/watch?v=8PopR3x-VMY 

2. How to Download and Install C Cpp Toolset ( gcc g++ gdb ) in Windows 10 using 

mingw-w64 and msys2: 

https://www.youtube.com/watch?v=0HD0pqVtsmw 

3. How to Set up Visual Studio Code for C and C++ Programming: 

https://www.youtube.com/watch?v=77v-Poud_io 

Installation: 

1. Microsoft Visual Code: https://code.visualstudio.com/download 

2. MSYS2 installer: 

https://github.com/msys2/msys2-installer/releases/download/2021-06-04/msys2-

x86_64-20210604.exe 

Tutorial ink: 

https://www.tutorialspoint.com/cprogramming/index.htm 

https://www.youtube.com/watch?v=8PopR3x-VMY
https://www.youtube.com/watch?v=0HD0pqVtsmw
https://www.youtube.com/watch?v=77v-Poud_io
https://code.visualstudio.com/download
https://github.com/msys2/msys2-installer/releases/download/2021-06-04/msys2-x86_64-20210604.exe
https://github.com/msys2/msys2-installer/releases/download/2021-06-04/msys2-x86_64-20210604.exe
https://www.tutorialspoint.com/cprogramming/index.htm
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Practical 12: Hands on Decision Support System and Crop Simulation 

Model: DSSAT 

 Objective: To learn about how a decision support system works through DSSAT (Decision 

Support System for Agrotechnology Transfer) 

 Requirement: Windows OS. 

 DSSAT: The Decision Support System for Agrotechnology Transfer (DSSAT) is a software 

application program that comprises crop simulation models for over 42 crops  as well as tools 

to facilitate effective use of the models. The tools include database management programs for 

soil, weather, crop management and experimental data, utilities, and application programs. The 

crop simulation models simulate growth, development and yield as a function of the soil-plant-

atmosphere dynamics. 

 

 How to use: 

 Agronomic Study:  

DSSAT provides at least one real experimental data for each of the crops that can be simulated. 

This includes the daily weather data, soil surface and profile information, detailed crop 

management and some observations. 

In order to run DSSAT for the example agronomy studies: 

 Open the DSSAT Shell from your desktop icon or App. 

 In the middle panel you find the Selector for Crops. Select the type of crop you are 

interested in and then the specific crop. In the panel on the right-hand side a list of one 
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or more experiments will appear. These are all real experiments that have been 

conducted in the past. 

 Select the experiment you would like to simulate. By default all treatments associated 

with that experiment are selected. 

 Then Click on the Run option on top of the DSSAT panel next to the lightning bold. 

 A new window will open that will show all treatments that will be simulated. Select 

Run Model and the Cropping System Model of DSSAT will run in the background, 

starting at planting or the start of simulation date and ending when the model predicts 

harvest maturity or when the user has defined final harvest. 

 Upon completion of all the simulations a “Simulations are completed” window pops 

up. Select the Analysis Tab and a list of output files will appear. 

This Agronomic Studies section of DSSAT represented under the “Crops Selector” panel 

should only be used for crop model calibration, especially for the cultivar, variety, hybrid, or 

clone genetic coefficients, and model evaluation in response to different management inputs or 

environment. 

Seasonal and Risk Analysis:  

Risk analysis is one of the main applications of DSSAT and allows users to evaluate alternate 

management practices for single growing seasons that account for both weather and economic 

uncertainty. Using the seasonal analysis option of DSSAT, a user can compare the interaction 

of genotype and management for different environments, especially long-term historical 

weather data. In a standard risk analysis approach a user defines at least two or more 

management scenarios. Normally for the weather inputs at least 30 years of historical weather 

data are selected, analogous to climate normals that are based on 30 years of historical weather 

data. 

Conclusion: 

Video Link: https://www.youtube.com/watch?v=T0V29FSfZJ4&t=167s 

 

 

 

 

 

https://www.youtube.com/watch?v=T0V29FSfZJ4&t=167s
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Practical 13: Introduction to Geospatial Technology for generating valuable 

information for Agriculture 

Objective: To acquire data that is referenced to the earth and use it for analysis, modelling 

,simulations and visualization. 

Software: Quantum GIS 3.6.3, Google Earth Pro 

System/Hardware Requirements: 

 Processor-CPU : core i7 64 bit Processor 

 Memory RAM : 8 GB or more 

 Hard Disk : SSD de 128 Gb or 500 Gb SATA 

 Graphic card : 2 Gb RAM 

 Operating System : Windows 10 

Web Browser : Google Chorme 

Downloading Google Earth Pro: https://google-earth-pro.en.lo4d.com/windows 

Google Earth Pro is a free to download vast database of 3D imagery of the planet and other 

geographic information that exists on your desktop. With Google Earth Pro, all users are now 

allowed to access high-quality and high-resolution aerial photography and ground images  

 

Downloading QGIS Software:  http://www.qgis.org/en/site/forusers/download.html 

Quantum GIS is an Open Source Geographic Information System. The QGIS software 

package currently runs on most versions of Unix, Windows and Mac OS X and supports a 

number of common raster and vector data formats. QGIS is available under the GNU General 

Public License (GPL). 

 

 

https://google-earth-pro.en.lo4d.com/windows
http://www.qgis.org/en/site/forusers/download.html
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Methodology: 

Open Raster Data:  

1. Open QGIS software 
2. Import the raster layer 

Digitization (Vector data creation): 

Digitization is the process of converting analog data into digital data sets. In GIS context 

digitization refers to creating vector datasets viz., point, line or polygon from raster datasets.  

With the help of digitization we can create different set of layers Viz. Rivers, roads, schools, 

ward boundaries and building blocks from a single map; this process is known as 

Vectorization.  

 

 

 

 

 

 

 

 

 

Vector data is mainly of three types- 

1) Point, 2) Line and 3) Polygon 

Methodology: 

3. Open QGIS software 

4. Import the raster layer 

5. Create a new shapefile layer 

6. Choose the type of features (point, line or polygon)  

7. Save the file with projection system 

8. Select the file in the layer panel  

9. Digitize the features using Add feature tool  
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Field data collection using GPS device and data import to QGIS 

Objective: To collect the field data (location) and import data to GIS system 

 

Instrument: GPS Garmin e trex 10 
 

Methodology: 

1. Visit to the field. Collect the location (longitude and latitude) data using GPS device. 

2. Note the location data. Save the data in a “.csv” (comma separated value) file 

3. Import the “.csv” file in the QGIS through: Layer          Add layer          Add delimited 

text layer 

4. Data is imported as point file in the GIS system 

5. Export the file as a “.shp” file (vector file) 

6. Open the attribute table of the vector file 

7. Activate the “toggle editing” and add a new filed in the attribute table.  

8. Fill the newly added fields with the information collected during field visit 

corresponding to a particular location 

Collection of open source satellite data 

Objective: To know and collect the open source satellite images. 

Bhuvan an ambitious project of ISRO(Indian space research organization) to take Indian images and thematic 

information in multiple spatial resolutions to people with a web portal through easy access to information on 

basic natural resources in the geospatial domain. Bhuvan showcases Indian images by the superimposition of the 

IRS satellite imageries on 2D/ 3D virtual globe. 

1) Go to Google Chrome  

2) Serach bhuvan.nrsc.gov.in 

3)  Welcome to Bhuvan > Open data Archive > Log in > Insert valid entries for your name, email, and 

location. Profile .Click Submit. 

4) after registering > go to login option > to start download 
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Vegetation indices 

Objective: commonly used to indicate the amount and health of vegetation in an image, and 

to differentiate vegetation, soil and water in forest. 

The vegetation index is an indicator that is calculated as a result of operations with different 

spectral ranges of remote sensing data and is related to the vegetation parameters in a particular 

pixel of the image. The effectiveness of vegetation indices is determined by the characteristics 

of reflection. The calculation of most of the vegetation indices is based on two the most stable 

sections of the curve spectral reflectance of plants. 

1) NDVI - normalized difference vegetation index. NDVI is an image transformation 

technique used to monitor the vegetation condition. NDVI is a combination of addition, 

subtraction and division. The index for NDVI of a LISS III image is (band4-

band3)/(band4+band3) 

 

 

Pixel value in the resultant image varies between -1.0 and +1.0.NDVI of an area containing a 

dense vegetation canopy will tend to positive values (say 0.3 to 0.8) while clouds, water and 

snow fields will be characterized by negative values of this index. Other targets show values 

near 0;e.g.,soils generally show values between 0.1 and 0.2.Very high positive values(say 0.6 

to 0.8)indicate healthy vegetation, while value-range 0.3 to 0.6 may be considered as stressed 

vegetation. However,this may vary from species to species and season to season. 

How to calculate NDVI 

Objective: To compute NDVI in QGIS software 

Software: Quantum GIS 3.6.3 

Data requirement: NIR BAND,RED BAND 

Workflow:  

1) Open Quantum GIS 3.6.3 

2) Import NIR BAND and  RED BAND 

3) Go to Raster menu > Raster calculator 
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Exercise: 

1) Which of the following statement is true? 

A)  QGIS is a proprietary software 

B) QGIS is an open source cross platform 

C) QGIS can’t be downloaded freely 

D) All the above 

2) What does the abbreviation QGIS stands for? 

A) Qualitative Geographic Information System 

B) Quantum Geographic Information System 

C) Quick user Geographic Information System 

D) Quarterly Geographic Information System 

3) Three basic symbol types for vector data- 

 

 a) Cells,Dots and Triangles 

 b) Points,squares and Plygons 

 c) 2D, 3D, and Hybrid 

 d) Points,lines and polygons  

 

4)  The difference between Raster and Vector is: 

  a) Raster is composed by pixels and vector is composed paths 

  b) Vector represents images and Raster represents points,lines and polygons 

  c) Raster represents data as cell or grid while Vector represents data using sequential points 

or vertices. 

 

5) Which instrument is used in field data collection? 

6) ISRO stands for………………………………………………………………….. 
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7) What is the range of NDVI? 

 

8) Which of the band has the highest reflectance for Vegetation? 

 

 

Conclusion: 

 

 

 

 

 

 

 

Video tutorial link: 

https://youtu.be/08eufydgv5c 

https://youtu.be/H5DwXK7EMXk 

https://youtu.be/WIP1genuoVo 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://youtu.be/08eufydgv5c
https://youtu.be/H5DwXK7EMXk
https://youtu.be/WIP1genuoVo
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Practical 13: Computation of water requirement of crop using CROPWAT 

8.0 and CLIMWAT 2.0 

 Objective: To learn about how to estimate crop water requirement using CROPWAT 8.0 and 

CLIMWAT 2.0. 

 Requirement: Windows OS. 

 Crop water requirement: Crop water requirement is the amount of water which is needed by 

crop or plant in order to replace the water which is lost by evapotranspiration. 

 CROPWAT: CROPWAT irrigation management model is a decision support tool investigated 

by food and agricultural organization called FAO. 

 

 CLIMWAT: CLIMWAT is a climatic database to be used in combination with the computer 

program CROPWAT and allows the calculation of crop water requirements. 
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 CROPWAT 8.0 is interactive in nature and can execute the following tasks very quickly:  

 Calculates the potential evapotranspiration (ETo) based on monthly climatic data;  

 Calculates the crop water requirements on a decade (10-day) basis based on ETo and 

crop data;  

 Calculates effective rainfall based on dependable rainfall data; and  

 Calculates the irrigation water requirement and irrigation scheduling based on crop 

data, soil data and the selected irrigation scheduling criteria. 

 Potential evapotranspiration: The influence of the climate on crop water need is given by the 

potential evapotranspiration or reference crop evapotranspiration (ETo). 

The CROPWAT 8 software employs the FAO Penman-Monteith method for determining 

reference crop evapotranspiration (ETo). This method calculates the ETo of an area based on 

the temperature, humidity, wind speed and sunshine data. 

 PROCEDURE:  

 Start CROPWAT 8 software.  

 Go to “Settings” on the top horizontal menu of the main screen and select “Options” 

 Based on available data select “ETo Penman-Monteith method” dropdown menu 

and press “OK”.  

 Select “Climate/ETo” icon from the left vertical menu of the main screen and 

enter the required location and temperature data. 

  

 Enter Location data 

 Save the file in a folder for future use.  

 Right click on the small “Monthly ETo Penman-Monteith” screen and select “Copy 

table >> Data and Headers” 
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 Crop water requirement 

Crop water requirement (ETc or CWR) is the quantity of water required by a crop in a given 

period of time for its normal growth under field condition at a specific place. 

 Net irrigation water requirement 

The water demand of crops can be supplied by either rainfall, irrigation or a combination of 

both. The net irrigation water requirement of a certain crop is the difference between the crop 

water requirement and part of the rainfall which can be used by the crop (the effective rainfall, 

Pe). 

PROCEDURE  

 Determination of effective rainfall 

 Go to “Settings” on the top horizontal menu of the main screen and select “Options” 

 Click the “Rainfall” icon, select the “Dependable rain (FAO/AGLW formula)” option 

and press “OK”. 

 Select the “Rain” icon from the left vertical menu of the main screen and enter the 

location name and rainfall data 

 Save the file in a folder you have created for future use. 

 Crop type and cropping pattern data: 

 Select the “Crop” icon from the left vertical menu followed by “Open” from the second 

row of the top horizontal menu from the main screen and the screen given below will 

appear. 

 Click the “FAO” folder and select your crop 

 Check the crop data and make corrections if necessary 
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 Enter the crop planting date 

 Save the file in the folder you have created for future use. 

Cropping Pattern:  

 Select the “Crop pattern” icon from the left vertical menu of the main screen 

 Fill in the “Cropping pattern name” 

 Now, place the cursor in the number 1 box under the “Crop file”, click the icon in front 

of the box and select your crop from the “FAO” folder. 

 Enter the crop planting date and the percentage of total area planted to the crop. 

 Crop water requirement (CWR) and Net irrigation water requirement (NIR):  

 Now, CWR and NIR is now ready – All you need to do is click the “CWR” icon from 

the left vertical menu of the main screen.  

 Unlike the others, you don’t need to save this file for future use. It is calculated by the 

CROPWAT 8 based on the aforementioned climatic and crop data.  

 

 

 

 

 

 

 

 

Exercise:  

1. Calculate ET0, Effective Rainfall, CWR and NIR of your nearest place using 

CROPWAT 8.0 and CLIMWAT 2.0. 

Conclusion:  

 

 

Video Link: https://www.youtube.com/watch?v=9mCED2tfqAY 
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Practical 15: Preparation of contingent crop plan 

 Objective: To learn about different contingent crop plan. 

 Contingency plan: Contingency plan is a plan devised for an outcome other than usual plan. 

 Contingency Crop plan:  Contingency crop plan can be defined as a plan aimed and executed 

for an outcome other than in the usual and expected plan. In other words, it is frequently used 

for risk management when an exceptional risk occurs in future. 

 Stepwise preparation of contingent crop plan:  

The types are: 

1. Inadequate and Uneven distribution of rainfall. 

2. Long gap of rainfall. 

3. Early onset of monsoon. 

4. Late onset of monsoon. 

5. Easy cessation of rains. 

6. Prolonged dry spells. 

 Contingent crop plan #1:  

Inadequate and uneven distribution of rainfall: 

a) Cultivation of low water required crops 

b) Short duration crops grown 

c) Providing lifesaving irrigation. 

 Contingent crop plan #2: 

Long gap in rainfall 

a) Increase in seed rate to obtain more population 

b) Spraying urea solution 

c) Providing lifesaving irrigation 

d) Weeding and intercultural operations 

 Contingent crop plan #3: 

Early onset of monsoon: 

a) Cultivate Pearl millet, Seasmum 

 Contingent crop plan #4: 

Late onset of monsoon: 

a) Alternate crops and varities: Castor, green gram, cowpea, sunflower. 

b) Dry sowing/ Kura sowing  
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c) Pre-sowing  

d) Seed soaking/ treatments 

e) Transplanting of one month old Bajra seedling 

f) Complete weed control 

g) Grow legumes/ oilseed crops I place of seeds. 

 Contingent cop plan #5 

Early cessation of rains: 

a) Mulching 

b) Lifesaving irrigation 

c) Decrease in plant population. 

 Contingent crop plan #6 

Prolonged dry spells: 

a) If 10 days dry spells in DAS then resowing. 

b) If mild moisture stress at 30-35 DAS, thinning of alternate rows of Sorghum and Pearl 

millet 

c) If severe moisture stress at 30-35 DAS, cutting of Sorghum and Pearl millet and 

ratooning. 

d) If moisture stress at blooming stage, cutting of sorghum ad pearl millet. 

e) In-situ water harvesting 

f) Lifesaving irrigation 

g) Wider spacing for moisture conservation 

h) Weed control to save water, nutrients. 

 Online Contingency Crop Planning 

1. Go to the link: https://agricoop.nic.in/en/agriculture-contingency-plan-listing 

2. Choose any State 

3.  Choose the districts for which you want contingency crop planning and you will get 

Agriculture Contingency Plan for District 

OR 

1. Go to the link: http://www.nicra-icar.in/nicrarevised/index.php/state-wise-plan 

2. Choose any State 

3.  Choose the districts for which you want contingency crop planning and you will get 

Agriculture Contingency Plan for District 

https://agricoop.nic.in/en/agriculture-contingency-plan-listing
http://www.nicra-icar.in/nicrarevised/index.php/state-wise-plan
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Exercise:  

1. State the steps to find contingency crop plan for your home district.  

Conclusion: 

Video Link: https://youtu.be/0RcGJKtHhcU 

https://youtu.be/0RcGJKtHhcU
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Syllabus (According to ICAR 5th Dean Committee report) 

Study of Computer Components, accessories, practice of important DOS Commands. 

Introduction of different operating systems such as windows, Unix/ Linux, Creating, Files & 

Folders, File Management. Use of MS-WORD and MS Power-point for creating, editing and 

presenting a scientific Document. MS-EXCEL - Creating a spreadsheet, use of statistical tools, 

writing expressions, creating graphs, analysis of scientific data. MS-ACCESS: Creating 

Database, preparing queries and reports, demonstration of Agri-information system. 

Introduction to World Wide Web (WWW). Introduction of programming languages. Hands on 

Crop Simulation Models (CSM) such as DSSAT /Crop-Info/ CropSyst/ Wofost; Computation 

of water and nutrient requirements of crop using CSM and IT tools. Introduction of Geospatial 

Technology for generating valuable information for Agriculture. Hands on Decision Support 

System. Preparation of contingent crop planning. Forecasting and early warning. 
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Lesson Plan: 

1 (P) Study of computer components and accessories 

2 (P) Practice of important DOS commands 

3 
(P) Introduction to different operating systems such as MS-Windows, Unix/ 

Linux, Creating Files and Folders, File Management 

4 (P) Use of Microsoft Word 

5 (P) MS Excel Mathematical calculations, Preparation of Spread Sheets 

6 (P) MS Excel chart –Line, XY, Bar and Pie 

7 (P) MS-Access: Creating Database, Preparation of queries, reports and forms 

8 (P) Microsoft PowerPoint 

9 (P) Basic concept of HTML for creating a Web page 

10 (P) Demonstration of Agri-information Systems 

11 (P) Introduction to Programing Language : C 

12 (P) Hands on Decision Support System and Crop Simulation Model: DSSAT 

13 
(P) Introduction to Geospatial Technology for generating valuable information 

for Agriculture 

14 
(P) Computation of water requirement of crop using CROPWAT 8.0 and 

CLIMWAT 2.0 

15 (P) Preparation of contingent crop plan 

 


